summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-03-08 15:47:26 +0100
committerAlexis Ballier <aballier@gentoo.org>2022-03-08 17:16:41 +0100
commit5d45fd6e134e8276337a3e1a663a15fc46d1ca82 (patch)
tree274c2d62f06c381da2b55c792b273c5aaf98f871 /dev-ros/rosnode/rosnode-1.15.14.ebuild
parentdev-ros/rosmsg: Bump to 1.15.14. (diff)
downloadgentoo-5d45fd6e134e8276337a3e1a663a15fc46d1ca82.tar.gz
gentoo-5d45fd6e134e8276337a3e1a663a15fc46d1ca82.tar.bz2
gentoo-5d45fd6e134e8276337a3e1a663a15fc46d1ca82.zip
dev-ros/rosnode: Bump to 1.15.14.
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosnode/rosnode-1.15.14.ebuild')
-rw-r--r--dev-ros/rosnode/rosnode-1.15.14.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/rosnode/rosnode-1.15.14.ebuild b/dev-ros/rosnode/rosnode-1.15.14.ebuild
new file mode 100644
index 000000000000..c5791a712db3
--- /dev/null
+++ b/dev-ros/rosnode/rosnode-1.15.14.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS nodes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ )"