summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-20 14:31:30 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-20 16:21:45 +0100
commitb4469ce95e32c4a32800b43d6ba489eea0dfb2bb (patch)
treec71ebf4e60d59195d8815938f236d56593cb0a52 /dev-ros/rosconsole
parentdev-ros/rosbag_storage: Bump to 1.12.7. (diff)
downloadgentoo-b4469ce95e32c4a32800b43d6ba489eea0dfb2bb.tar.gz
gentoo-b4469ce95e32c4a32800b43d6ba489eea0dfb2bb.tar.bz2
gentoo-b4469ce95e32c4a32800b43d6ba489eea0dfb2bb.zip
dev-ros/rosconsole: Bump to 1.12.7.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rosconsole')
-rw-r--r--dev-ros/rosconsole/Manifest1
-rw-r--r--dev-ros/rosconsole/rosconsole-1.12.7.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/rosconsole/Manifest b/dev-ros/rosconsole/Manifest
index fad38b8610f8..1dc7adec7f13 100644
--- a/dev-ros/rosconsole/Manifest
+++ b/dev-ros/rosconsole/Manifest
@@ -1,2 +1,3 @@
DIST ros_comm-1.12.5.tar.gz 966478 SHA256 a53039f5106133b67689ba579e29c9045e3b1468713019cf72b848ce979b6964 SHA512 0d97eac0b0cf200a1e217597176d55c82249e2e7b9f3c4706dce84068a65c6642e099fb16c69d33b62d6c780d2c2775b7330fb497bc936f9d4bc73a2b5ba12ca WHIRLPOOL 3f1c8239ef146a0915b8f2c183c68eda094f480fa099846c6b152325bd1e8574114ecbb4a5bcd609bf1323f29767dc8110e175c79b07183cc8ff9e51f9a62b19
DIST ros_comm-1.12.6.tar.gz 967763 SHA256 8585d952b1168d2011949b38c68160180b1f3ee1648a506bcb5989f9807335ca SHA512 1987c6362ae0c7c019a226223c73a7aefdc14a3fc66469ab6cdf9c41e9efdf4d7b7d4932af2a52f2082d716342a307b2e415c0ab45f77dfd9a7c1e4274deab5c WHIRLPOOL a719bb81da6b1b7e2f253d3bf6c8db8339333b4fa7f89a18d0fa734e9ff1700e1dac7b537f154015b4ada7455a6673c1715a89e2fdd3da9bbbb70081fc2943cd
+DIST ros_comm-1.12.7.tar.gz 974568 SHA256 4c141270c9263ba1ceb0d510f9d17bfe229530a277bfe10762e88d25f46efd38 SHA512 7cfc5bf231e8e388102f192d46bd902a2b92d4620938379b362efd250c48f317f5ba6e0aee7398c841392f56c2b79f933ad5ec60eb69492add90fa2ca86a3a8f WHIRLPOOL 7537aa5b781b3426cbaa82bdb07b117045efc3f748af7413e6b52ee63f3b401e403966afb1ea305674a5613f6a191f0afa098ad16e63267ad2ec8e3117996eb0
diff --git a/dev-ros/rosconsole/rosconsole-1.12.7.ebuild b/dev-ros/rosconsole/rosconsole-1.12.7.ebuild
new file mode 100644
index 000000000000..b26b7ce325bc
--- /dev/null
+++ b/dev-ros/rosconsole/rosconsole-1.12.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS console output library"
+LICENSE="BSD"
+SLOT="0"
+IUSE="+log4cxx glog"
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+ dev-ros/rosunit
+ dev-libs/boost:=[threads]
+ log4cxx? ( dev-libs/log4cxx )
+ !log4cxx? ( glog? ( dev-cpp/glog ) )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local ROSCONSOLE_BACKEND=""
+ if use log4cxx; then
+ ROSCONSOLE_BACKEND="log4cxx"
+ elif use glog; then
+ ROSCONSOLE_BACKEND="glog"
+ else
+ ROSCONSOLE_BACKEND="print"
+ fi
+ local mycatkincmakeargs=( "-DROSCONSOLE_BACKEND=${ROSCONSOLE_BACKEND}" )
+ ros-catkin_src_configure
+}