summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-26 09:22:44 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-26 09:24:16 +0100
commitb8ea23037b789921f69c247732d76ae087c2c891 (patch)
tree893c5dc76516e96f1cc597db3c66322628b87a52 /dev-ros/rosapi/rosapi-0.7.17.ebuild
parentros-meta/imu_pipeline: Bump to 0.2.2. (diff)
downloadgentoo-b8ea23037b789921f69c247732d76ae087c2c891.tar.gz
gentoo-b8ea23037b789921f69c247732d76ae087c2c891.tar.bz2
gentoo-b8ea23037b789921f69c247732d76ae087c2c891.zip
dev-ros/rosapi: Bump to 0.7.17.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rosapi/rosapi-0.7.17.ebuild')
-rw-r--r--dev-ros/rosapi/rosapi-0.7.17.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/rosapi/rosapi-0.7.17.ebuild b/dev-ros/rosapi/rosapi-0.7.17.ebuild
new file mode 100644
index 000000000000..547cfde4ccd9
--- /dev/null
+++ b/dev-ros/rosapi/rosapi-0.7.17.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides service calls for getting ros meta-information, like list of topics, services, params, etc."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosbridge_library[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"