summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-15 17:54:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-15 18:57:09 +0200
commit0ff9b2ffcf02a25c4c83eddb6aa252906e499ddb (patch)
treea2943aaee44ba15df1b9cf4505d167035415c1fb /dev-ros/robot_pose_ekf
parentdev-ros/robot_pose_publisher: bump eapi (diff)
downloadgentoo-0ff9b2ffcf02a25c4c83eddb6aa252906e499ddb.tar.gz
gentoo-0ff9b2ffcf02a25c4c83eddb6aa252906e499ddb.tar.bz2
gentoo-0ff9b2ffcf02a25c4c83eddb6aa252906e499ddb.zip
dev-ros/robot_pose_ekf: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/robot_pose_ekf')
-rw-r--r--dev-ros/robot_pose_ekf/robot_pose_ekf-9999.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/dev-ros/robot_pose_ekf/robot_pose_ekf-9999.ebuild b/dev-ros/robot_pose_ekf/robot_pose_ekf-9999.ebuild
index 9133c4a8d19d..e8183b8ee6dc 100644
--- a/dev-ros/robot_pose_ekf/robot_pose_ekf-9999.ebuild
+++ b/dev-ros/robot_pose_ekf/robot_pose_ekf-9999.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-planning/navigation"
ROS_SUBDIR=${PN}
KEYWORDS="~amd64 ~arm"
CATKIN_HAS_MESSAGES=yes
-PYTHON_COMPAT=( python2_7 )
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
inherit ros-catkin
-DESCRIPTION="Estimate the 3D pose of a robot, based on (partial) pose measurements coming from different sources"
+DESCRIPTION="Estimate the 3D pose of a robot from pose measurements from various sources"
LICENSE="BSD"
SLOT="0"
IUSE=""
@@ -19,12 +18,12 @@ IUSE=""
RDEPEND="
dev-ros/roscpp
dev-ros/tf
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
sci-libs/orocos-bfl
dev-libs/boost:=[threads]
"
DEPEND="${RDEPEND}
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
virtual/pkgconfig"