summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-04 20:26:51 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-04 20:46:30 +0200
commitb727642ed8b2c9e910725acafbbd078574fbac92 (patch)
tree38ca136a7e5131c569b347d6dca0abe70a653138 /dev-ros/qt_dotgraph/qt_dotgraph-0.3.9.ebuild
parentdev-lisp/sbcl: Bump version to 1.4.10 (diff)
downloadgentoo-b727642ed8b2c9e910725acafbbd078574fbac92.tar.gz
gentoo-b727642ed8b2c9e910725acafbbd078574fbac92.tar.bz2
gentoo-b727642ed8b2c9e910725acafbbd078574fbac92.zip
dev-ros/qt_dotgraph: Bump to 0.3.9.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-ros/qt_dotgraph/qt_dotgraph-0.3.9.ebuild')
-rw-r--r--dev-ros/qt_dotgraph/qt_dotgraph-0.3.9.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/qt_dotgraph/qt_dotgraph-0.3.9.ebuild b/dev-ros/qt_dotgraph/qt_dotgraph-0.3.9.ebuild
new file mode 100644
index 000000000000..e833e27d3446
--- /dev/null
+++ b/dev-ros/qt_dotgraph/qt_dotgraph-0.3.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Helpers to work with dot graphs"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/pydot[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ )"