summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 13:38:19 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 13:45:32 +0200
commit1b43a58aee1802fabffb599f37ca1df408e77f17 (patch)
tree3abd4bcf6a0c2b0471aecd3144c28b6b352d8caf /dev-ros/image_publisher
parentdev-ros/image_rotate: Remove old (diff)
downloadgentoo-1b43a58aee1802fabffb599f37ca1df408e77f17.tar.gz
gentoo-1b43a58aee1802fabffb599f37ca1df408e77f17.tar.bz2
gentoo-1b43a58aee1802fabffb599f37ca1df408e77f17.zip
dev-ros/image_publisher: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/image_publisher')
-rw-r--r--dev-ros/image_publisher/image_publisher-1.15.2.ebuild8
-rw-r--r--dev-ros/image_publisher/image_publisher-9999.ebuild10
2 files changed, 9 insertions, 9 deletions
diff --git a/dev-ros/image_publisher/image_publisher-1.15.2.ebuild b/dev-ros/image_publisher/image_publisher-1.15.2.ebuild
index ffda07317a22..34d0c0948d93 100644
--- a/dev-ros/image_publisher/image_publisher-1.15.2.ebuild
+++ b/dev-ros/image_publisher/image_publisher-1.15.2.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
inherit ros-catkin
@@ -23,7 +22,8 @@ RDEPEND="
dev-ros/nodelet
dev-libs/console_bridge:=
dev-ros/roscpp
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-libs/boost:=
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
diff --git a/dev-ros/image_publisher/image_publisher-9999.ebuild b/dev-ros/image_publisher/image_publisher-9999.ebuild
index 7a3fea27064f..34d0c0948d93 100644
--- a/dev-ros/image_publisher/image_publisher-9999.ebuild
+++ b/dev-ros/image_publisher/image_publisher-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
inherit ros-catkin
@@ -23,7 +22,8 @@ RDEPEND="
dev-ros/nodelet
dev-libs/console_bridge:=
dev-ros/roscpp
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-libs/boost:=
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"