summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-03 15:46:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-03 16:12:20 +0200
commit43acae5fae6ec15456039f9be02ddec40f916b67 (patch)
treed6020d4097881f42c3756b199ab587367b946adb /dev-ros/image_cb_detector
parentapp-office/kmymoney: Drop 5.1.1-r1 (diff)
downloadgentoo-43acae5fae6ec15456039f9be02ddec40f916b67.tar.gz
gentoo-43acae5fae6ec15456039f9be02ddec40f916b67.tar.bz2
gentoo-43acae5fae6ec15456039f9be02ddec40f916b67.zip
dev-ros/image_cb_detector: fix python script
Closes: https://bugs.gentoo.org/803011 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/image_cb_detector')
-rw-r--r--dev-ros/image_cb_detector/files/py3.patch22
-rw-r--r--dev-ros/image_cb_detector/image_cb_detector-0.10.15-r1.ebuild (renamed from dev-ros/image_cb_detector/image_cb_detector-0.10.15.ebuild)2
-rw-r--r--dev-ros/image_cb_detector/image_cb_detector-9999.ebuild2
3 files changed, 24 insertions, 2 deletions
diff --git a/dev-ros/image_cb_detector/files/py3.patch b/dev-ros/image_cb_detector/files/py3.patch
new file mode 100644
index 000000000000..54475afd66dc
--- /dev/null
+++ b/dev-ros/image_cb_detector/files/py3.patch
@@ -0,0 +1,22 @@
+Index: image_cb_detector/src/image_cb_detector/cb_detector.py
+===================================================================
+--- image_cb_detector.orig/src/image_cb_detector/cb_detector.py
++++ image_cb_detector/src/image_cb_detector/cb_detector.py
+@@ -39,7 +39,7 @@ NAME = 'image_cb_detector_node'
+ import roslib; roslib.load_manifest(PKG)
+
+ import rospy
+-import cv
++import cv2 as cv
+ import math
+
+ from sensor_msgs.msg import Image
+@@ -130,7 +130,7 @@ class ImageCbDetectorNode:
+ #we need to convert the ros image to an opencv image
+ try:
+ image = self.bridge.imgmsg_to_cv(ros_image, "mono8")
+- except CvBridgeError, e:
++ except CvBridgeError as e:
+ rospy.logerror("Error importing image %s" % e)
+ return
+
diff --git a/dev-ros/image_cb_detector/image_cb_detector-0.10.15.ebuild b/dev-ros/image_cb_detector/image_cb_detector-0.10.15-r1.ebuild
index 72b5cebfd88f..3cb98fba9da3 100644
--- a/dev-ros/image_cb_detector/image_cb_detector-0.10.15.ebuild
+++ b/dev-ros/image_cb_detector/image_cb_detector-0.10.15-r1.ebuild
@@ -30,4 +30,4 @@ DEPEND="${RDEPEND}
dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
-PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/c11.patch" )
+PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/c11.patch" "${FILESDIR}/py3.patch" )
diff --git a/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild b/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild
index 72b5cebfd88f..3cb98fba9da3 100644
--- a/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild
+++ b/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild
@@ -30,4 +30,4 @@ DEPEND="${RDEPEND}
dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
-PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/c11.patch" )
+PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/c11.patch" "${FILESDIR}/py3.patch" )