summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-07 20:16:01 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-07 20:23:54 +0100
commit4d53cbe2926530214f55b8773b3b2d45a2f2d7e7 (patch)
treebaf9594588803853c9b9292919d2175095ee0124 /dev-ros/camera_calibration_parsers
parentros-meta/image_common: Remove old (diff)
downloadgentoo-4d53cbe2926530214f55b8773b3b2d45a2f2d7e7.tar.gz
gentoo-4d53cbe2926530214f55b8773b3b2d45a2f2d7e7.tar.bz2
gentoo-4d53cbe2926530214f55b8773b3b2d45a2f2d7e7.zip
dev-ros/camera_calibration_parsers: Bump to 1.11.13.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/camera_calibration_parsers')
-rw-r--r--dev-ros/camera_calibration_parsers/Manifest1
-rw-r--r--dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.13.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/camera_calibration_parsers/Manifest b/dev-ros/camera_calibration_parsers/Manifest
index 6b743a505cb1..339b23d8bfca 100644
--- a/dev-ros/camera_calibration_parsers/Manifest
+++ b/dev-ros/camera_calibration_parsers/Manifest
@@ -1 +1,2 @@
DIST image_common-1.11.12.tar.gz 53920 SHA256 13d434e2d46e13af05398f3cbacffb2c69e2d015f6827d848f799a28d23e816d SHA512 cd64edd658092c88060a99bbf2cd501cd27441123c34914fc4c8d8c8a8a1fe6d4a929211e71d813b6eb72e1d844842ee3e12567bc40d32981db9ee430e61fb10 WHIRLPOOL 1f1922d9b004e4af7b2f42839b0cdaa8c31c8b187618267b3780f34a56f90a2f471b68bae3dd9bb8ccbb80d35dba41e05d49fcac6a1156e1c5ab2b8e79d3032d
+DIST image_common-1.11.13.tar.gz 54731 SHA256 32a2e07724dec6eaaace21eae006274436d70d40bfe205249438570275c43cac SHA512 154a1acfc3ee1be83828f7b86de8a5e02d7613d724f734409c5b93b1505bcf911b95f20fe43435932f49e03e286ed7055e2b7abeb1c5292f540a2299dd424bfa WHIRLPOOL fed16f5148355b3e9e64e734b6f22c37f310e58c22e86446f1068bf00e155fe0b2c20a546da03edc75ddbd87d3528cc4d397f46b55599b59df4700163fa724b9
diff --git a/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.13.ebuild b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.13.ebuild
new file mode 100644
index 000000000000..e319da058e83
--- /dev/null
+++ b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.13.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit ros-catkin
+
+DESCRIPTION="Routines for reading and writing camera calibration parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ dev-ros/rosconsole
+ >=dev-cpp/yaml-cpp-0.5
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/nose )
+"
+PATCHES=( "${FILESDIR}/boostpython.patch" )