summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-01 13:54:32 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-01 14:01:30 +0200
commit913c3346be1f5734f82bf6cea8d0fab1c4889daa (patch)
tree73d225a78d790a6cadce309b927829c774f8ff4f /dev-ros/bondpy/bondpy-1.8.0.ebuild
parentdev-ros/bondcpp: Bump to 1.8.0. (diff)
downloadgentoo-913c3346be1f5734f82bf6cea8d0fab1c4889daa.tar.gz
gentoo-913c3346be1f5734f82bf6cea8d0fab1c4889daa.tar.bz2
gentoo-913c3346be1f5734f82bf6cea8d0fab1c4889daa.zip
dev-ros/bondpy: Bump to 1.8.0.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ros/bondpy/bondpy-1.8.0.ebuild')
-rw-r--r--dev-ros/bondpy/bondpy-1.8.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/bondpy/bondpy-1.8.0.ebuild b/dev-ros/bondpy/bondpy-1.8.0.ebuild
new file mode 100644
index 000000000000..1944a1c798b6
--- /dev/null
+++ b/dev-ros/bondpy/bondpy-1.8.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Python implementation of bond, a mechanism for checking when another process has terminated"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bond[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/smclib
+ sys-apps/util-linux
+"
+DEPEND="${RDEPEND}"