summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-02 12:26:03 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-02 13:51:30 -0400
commitbb6ad6b24b9f801287def9321f83cb450ecfa9c6 (patch)
tree8dcf435c1acfd6802acc5564c6ae7bcb3ea39515 /dev-qt
parentdev-qt/qttools: update live (diff)
downloadgentoo-bb6ad6b24b9f801287def9321f83cb450ecfa9c6.tar.gz
gentoo-bb6ad6b24b9f801287def9321f83cb450ecfa9c6.tar.bz2
gentoo-bb6ad6b24b9f801287def9321f83cb450ecfa9c6.zip
dev-qt/qtwebengine: update live
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.7.9999.ebuild13
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.8.9999.ebuild18
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.9999.ebuild18
3 files changed, 12 insertions, 37 deletions
diff --git a/dev-qt/qtwebengine/qtwebengine-6.7.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-6.7.9999.ebuild
index 4315b3198309..068abfec79cb 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.7.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.7.9999.ebuild
@@ -203,8 +203,8 @@ src_configure() {
# cooperate with new major ffmpeg versions (bug #831487)
-DQT_FEATURE_webengine_system_ffmpeg=OFF
- # use bundled re2 to avoid complications, may revisit
- # (see discussions in https://github.com/gentoo/gentoo/pull/32281)
+ # use bundled re2 to avoid complications, Qt has also disabled
+ # this by default in 6.7.3+ (bug #913923)
-DQT_FEATURE_webengine_system_re2=OFF
# bundled is currently required when using vaapi (forced regardless)
@@ -243,15 +243,6 @@ src_configure() {
use arm64 && tc-is-gcc && filter-flags '-march=*' '-mcpu=*'
fi
- # Workaround for build failure with clang-18 and -march=native without
- # avx512. Does not affect e.g. -march=skylake, only native (bug #931623).
- # TODO: drop this when <=llvm-18.1.5-r1 >=18 been gone for some time
- use amd64 && tc-is-clang && is-flagq -march=native &&
- [[ $(clang-major-version) -ge 18 ]] &&
- has_version '<sys-devel/llvm-18.1.5-r1' &&
- tc-cpp-is-true "!defined(__AVX512F__)" ${CXXFLAGS} &&
- append-flags -mevex512
-
export NINJA NINJAFLAGS=$(get_NINJAOPTS)
[[ ${NINJA_VERBOSE^^} == OFF ]] || NINJAFLAGS+=" -v"
diff --git a/dev-qt/qtwebengine/qtwebengine-6.8.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-6.8.9999.ebuild
index 937f5ca9c883..fa19dc8fba43 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.8.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.8.9999.ebuild
@@ -88,7 +88,6 @@ DEPEND="
x11-libs/libxshmfence
opengl? ( media-libs/libglvnd[X] )
screencast? ( media-libs/libepoxy[egl(+)] )
- pdfium? ( net-print/cups )
test? (
widgets? ( app-text/poppler[cxx(+)] )
)
@@ -192,7 +191,8 @@ src_configure() {
$(qt_feature vulkan webengine_vulkan)
-DQT_FEATURE_webengine_embedded_build=OFF
-DQT_FEATURE_webengine_extensions=ON
- -DQT_FEATURE_webengine_ozone_x11=ON # needed, cannot do optional X yet
+ # TODO: it may be possible to make x11 optional since 6.8+
+ -DQT_FEATURE_webengine_ozone_x11=ON
-DQT_FEATURE_webengine_pepper_plugins=ON
-DQT_FEATURE_webengine_printing_and_pdf=ON
-DQT_FEATURE_webengine_spellchecker=ON
@@ -203,8 +203,8 @@ src_configure() {
# cooperate with new major ffmpeg versions (bug #831487)
-DQT_FEATURE_webengine_system_ffmpeg=OFF
- # use bundled re2 to avoid complications, may revisit
- # (see discussions in https://github.com/gentoo/gentoo/pull/32281)
+ # use bundled re2 to avoid complications, Qt has also disabled
+ # this by default in 6.7.3+ (bug #913923)
-DQT_FEATURE_webengine_system_re2=OFF
# bundled is currently required when using vaapi (forced regardless)
@@ -217,6 +217,7 @@ src_configure() {
minizip opus poppler snappy zlib)
# TODO: fixup gn cross, or package dev-qt/qtwebengine-gn with =ON
+ # (see also BUILD_ONLY_GN option added in 6.8+ for the latter)
-DINSTALL_GN=OFF
)
@@ -243,15 +244,6 @@ src_configure() {
use arm64 && tc-is-gcc && filter-flags '-march=*' '-mcpu=*'
fi
- # Workaround for build failure with clang-18 and -march=native without
- # avx512. Does not affect e.g. -march=skylake, only native (bug #931623).
- # TODO: drop this when <=llvm-18.1.5-r1 >=18 been gone for some time
- use amd64 && tc-is-clang && is-flagq -march=native &&
- [[ $(clang-major-version) -ge 18 ]] &&
- has_version '<sys-devel/llvm-18.1.5-r1' &&
- tc-cpp-is-true "!defined(__AVX512F__)" ${CXXFLAGS} &&
- append-flags -mevex512
-
export NINJA NINJAFLAGS=$(get_NINJAOPTS)
[[ ${NINJA_VERBOSE^^} == OFF ]] || NINJAFLAGS+=" -v"
diff --git a/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild
index 937f5ca9c883..fa19dc8fba43 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild
@@ -88,7 +88,6 @@ DEPEND="
x11-libs/libxshmfence
opengl? ( media-libs/libglvnd[X] )
screencast? ( media-libs/libepoxy[egl(+)] )
- pdfium? ( net-print/cups )
test? (
widgets? ( app-text/poppler[cxx(+)] )
)
@@ -192,7 +191,8 @@ src_configure() {
$(qt_feature vulkan webengine_vulkan)
-DQT_FEATURE_webengine_embedded_build=OFF
-DQT_FEATURE_webengine_extensions=ON
- -DQT_FEATURE_webengine_ozone_x11=ON # needed, cannot do optional X yet
+ # TODO: it may be possible to make x11 optional since 6.8+
+ -DQT_FEATURE_webengine_ozone_x11=ON
-DQT_FEATURE_webengine_pepper_plugins=ON
-DQT_FEATURE_webengine_printing_and_pdf=ON
-DQT_FEATURE_webengine_spellchecker=ON
@@ -203,8 +203,8 @@ src_configure() {
# cooperate with new major ffmpeg versions (bug #831487)
-DQT_FEATURE_webengine_system_ffmpeg=OFF
- # use bundled re2 to avoid complications, may revisit
- # (see discussions in https://github.com/gentoo/gentoo/pull/32281)
+ # use bundled re2 to avoid complications, Qt has also disabled
+ # this by default in 6.7.3+ (bug #913923)
-DQT_FEATURE_webengine_system_re2=OFF
# bundled is currently required when using vaapi (forced regardless)
@@ -217,6 +217,7 @@ src_configure() {
minizip opus poppler snappy zlib)
# TODO: fixup gn cross, or package dev-qt/qtwebengine-gn with =ON
+ # (see also BUILD_ONLY_GN option added in 6.8+ for the latter)
-DINSTALL_GN=OFF
)
@@ -243,15 +244,6 @@ src_configure() {
use arm64 && tc-is-gcc && filter-flags '-march=*' '-mcpu=*'
fi
- # Workaround for build failure with clang-18 and -march=native without
- # avx512. Does not affect e.g. -march=skylake, only native (bug #931623).
- # TODO: drop this when <=llvm-18.1.5-r1 >=18 been gone for some time
- use amd64 && tc-is-clang && is-flagq -march=native &&
- [[ $(clang-major-version) -ge 18 ]] &&
- has_version '<sys-devel/llvm-18.1.5-r1' &&
- tc-cpp-is-true "!defined(__AVX512F__)" ${CXXFLAGS} &&
- append-flags -mevex512
-
export NINJA NINJAFLAGS=$(get_NINJAOPTS)
[[ ${NINJA_VERBOSE^^} == OFF ]] || NINJAFLAGS+=" -v"