summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2023-09-24 23:48:01 +0800
committerWANG Xuerui <xen0n@gentoo.org>2023-09-25 01:05:19 +0800
commitefa8fedcff3a8c52d5cc6091d7cdd4b7971c9898 (patch)
tree10d45ff7a4be6bb2c378a91b65b4cbb1385e03fe /dev-qt/qtbase
parentapp-misc/fastfetch: keyword 2.0.5-r1 for ~loong (diff)
downloadgentoo-efa8fedcff3a8c52d5cc6091d7cdd4b7971c9898.tar.gz
gentoo-efa8fedcff3a8c52d5cc6091d7cdd4b7971c9898.tar.bz2
gentoo-efa8fedcff3a8c52d5cc6091d7cdd4b7971c9898.zip
dev-qt/qtbase: keyword 6.5.2-r2 for ~loong
Two test cases are failing on a Loongson 3A6000 box: 71 - tst_qprocess (Failed) 304 - tst_qnetworkinterface (Failed) With the following log messages: FAIL! : tst_QProcess::startStopStartStopBuffers(separate-separate) 'process.bytesToWrite() > 0' returned FALSE. () Loc: [/tmp/portage/dev-qt/qtbase-6.5.2-r2/work/qtbase-everywhere-src-6.5.2/tests/auto/corelib/io/qprocess/tst_qprocess.cpp(2461)] FAIL! : tst_QProcess::startStopStartStopBuffers(separate-merged) 'process.bytesToWrite() > 0' returned FALSE. () Loc: [/tmp/portage/dev-qt/qtbase-6.5.2-r2/work/qtbase-everywhere-src-6.5.2/tests/auto/corelib/io/qprocess/tst_qprocess.cpp(2461)] FAIL! : tst_QProcess::startStopStartStopBuffers(merged-separate) 'process.bytesToWrite() > 0' returned FALSE. () Loc: [/tmp/portage/dev-qt/qtbase-6.5.2-r2/work/qtbase-everywhere-src-6.5.2/tests/auto/corelib/io/qprocess/tst_qprocess.cpp(2461)] FAIL! : tst_QProcess::startStopStartStopBuffers(merged-merged) 'process.bytesToWrite() > 0' returned FALSE. () Loc: [/tmp/portage/dev-qt/qtbase-6.5.2-r2/work/qtbase-everywhere-src-6.5.2/tests/auto/corelib/io/qprocess/tst_qprocess.cpp(2461)] FAIL! : tst_QProcess::startStopStartStopBuffers(merged-forwarded) 'process.bytesToWrite() > 0' returned FALSE. () Loc: [/tmp/portage/dev-qt/qtbase-6.5.2-r2/work/qtbase-everywhere-src-6.5.2/tests/auto/corelib/io/qprocess/tst_qprocess.cpp(2461)] FAIL! : tst_QNetworkInterface::localAddress(wg0-xxx.xxx.xxx.xxx) 'pmtu <= outgoingIface->maximumTransmissionUnit()' returned FALSE. () Loc: [/tmp/portage/dev-qt/qtbase-6.5.2-r2/work/qtbase-everywhere-src-6.5.2/tests/auto/network/kernel/qnetworkinterface/tst_qnetworkinterface.cpp(246)] But both are spurious to some extent. For the startStopStartStopBuffers case, a 128KiB write is made to hopefully retain some unwritten data even if the pipe is found writable, and the comment in the test code indicates that Linux is the "worst case" defaulting to 64KiB pipe buffers. This is actually PIPE_DEF_BUFFERS pages, according to include/linux/pipe_fs_i.h; popular arches use 4KiB pages, so 64KiB for them. Linux/LoongArch defaults to 16KiB pages, however, and the test case passes when the write size is quadrupled. And for the localAddress case, it may just be that the WireGuard interface behaves differently than physical ones, and indeed the other interfaces passed the test. So, the library should actually be fully functional on loong, hence the keyword. Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
Diffstat (limited to 'dev-qt/qtbase')
-rw-r--r--dev-qt/qtbase/qtbase-6.5.2-r2.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-qt/qtbase/qtbase-6.5.2-r2.ebuild b/dev-qt/qtbase/qtbase-6.5.2-r2.ebuild
index 2f489c953187..67ce1f180005 100644
--- a/dev-qt/qtbase/qtbase-6.5.2-r2.ebuild
+++ b/dev-qt/qtbase/qtbase-6.5.2-r2.ebuild
@@ -8,7 +8,7 @@ inherit flag-o-matic qt6-build toolchain-funcs
DESCRIPTION="Cross-platform application development framework"
if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 ~arm ~arm64 ~hppa ~x86"
+ KEYWORDS="amd64 ~arm ~arm64 ~hppa ~loong ~x86"
fi
declare -A QT6_IUSE=(