summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-05 23:39:54 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-06 04:49:36 -0400
commit53c16fca587360f9975217ca0cea3393d7f85074 (patch)
tree4de7ae39cef6651c848e6501d724d95062926857 /dev-qt/qtbase
parentprofiles/features/wd40: tweak thin-provisioning-tools mask (diff)
downloadgentoo-53c16fca587360f9975217ca0cea3393d7f85074.tar.gz
gentoo-53c16fca587360f9975217ca0cea3393d7f85074.tar.bz2
gentoo-53c16fca587360f9975217ca0cea3393d7f85074.zip
dev-qt/qtbase: optionally pdepend on qttranslations
For qt6, had bit of a draft to "merge" qttranslations with their respective packages, plus a few splits for circular deps. But it all started to feel churny and looked like it would be a pain to maintain, prone to mistakes, and with very little to gain. Doing our own tarballs could work but still requires some tracking and writing scripts to handle it. And then I do not think translations should need to be emerged manually, it is something you can normally expect out of the box unless you opt-out. So let's just do the "nls? ( )" in qt6 even if runtime-only IUSE are kind of terrible on a large package like qtbase. Not unconditional given it does bring in linguist as extra, and translations are still a decent ~13MB installed. Live-only for now, no need to trigger rebuilds over this. Bug: https://bugs.gentoo.org/810802 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtbase')
-rw-r--r--dev-qt/qtbase/qtbase-6.5.9999.ebuild7
-rw-r--r--dev-qt/qtbase/qtbase-6.9999.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/dev-qt/qtbase/qtbase-6.5.9999.ebuild b/dev-qt/qtbase/qtbase-6.5.9999.ebuild
index 714ed0db12c8..9dff844569da 100644
--- a/dev-qt/qtbase/qtbase-6.5.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.5.9999.ebuild
@@ -24,7 +24,7 @@ declare -A QT6_IUSE=(
[sql]="mysql oci8 odbc postgres +sqlite"
[widgets]="cups gtk"
- [optfeature]="wayland" #864509
+ [optfeature]="nls wayland" #810802,864509
)
IUSE="${QT6_IUSE[*]}"
REQUIRED_USE="
@@ -124,7 +124,10 @@ DEPEND="
)
"
BDEPEND="zstd? ( app-arch/libarchive[zstd] )" #910392
-PDEPEND="wayland? ( ~dev-qt/qtwayland-${PV}:6 )"
+PDEPEND="
+ nls? ( ~dev-qt/qttranslations-${PV}:6 )
+ wayland? ( ~dev-qt/qtwayland-${PV}:6 )
+"
src_prepare() {
qt6-build_src_prepare
diff --git a/dev-qt/qtbase/qtbase-6.9999.ebuild b/dev-qt/qtbase/qtbase-6.9999.ebuild
index 15a3ab244492..a3394328ab7e 100644
--- a/dev-qt/qtbase/qtbase-6.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.9999.ebuild
@@ -24,7 +24,7 @@ declare -A QT6_IUSE=(
[sql]="mysql oci8 odbc postgres +sqlite"
[widgets]="cups gtk"
- [optfeature]="wayland" #864509
+ [optfeature]="nls wayland" #810802,864509
)
IUSE="${QT6_IUSE[*]}"
REQUIRED_USE="
@@ -124,7 +124,10 @@ DEPEND="
)
"
BDEPEND="zstd? ( app-arch/libarchive[zstd] )" #910392
-PDEPEND="wayland? ( ~dev-qt/qtwayland-${PV}:6 )"
+PDEPEND="
+ nls? ( ~dev-qt/qttranslations-${PV}:6 )
+ wayland? ( ~dev-qt/qtwayland-${PV}:6 )
+"
src_prepare() {
qt6-build_src_prepare