summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-03-06 23:08:33 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-03-07 00:17:19 +0000
commitf4e58189a64eab22cc26b9b64b7a104a68a4f9bf (patch)
tree70e020763c5a7202d231980febe5579fe2941ee1 /dev-python
parentdev-python/cloudpickle: version bump (diff)
downloadgentoo-f4e58189a64eab22cc26b9b64b7a104a68a4f9bf.tar.gz
gentoo-f4e58189a64eab22cc26b9b64b7a104a68a4f9bf.tar.bz2
gentoo-f4e58189a64eab22cc26b9b64b7a104a68a4f9bf.zip
dev-python/sortedcollections: initial import
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sortedcollections/Manifest1
-rw-r--r--dev-python/sortedcollections/metadata.xml15
-rw-r--r--dev-python/sortedcollections/sortedcollections-0.4.2.ebuild25
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sortedcollections/Manifest b/dev-python/sortedcollections/Manifest
new file mode 100644
index 000000000000..dd970ae26e43
--- /dev/null
+++ b/dev-python/sortedcollections/Manifest
@@ -0,0 +1 @@
+DIST sortedcollections-0.4.2.tar.gz 111533 SHA256 8aefd6cf0bb0a89888f192859c3dbf997b906b33cd4ce175d568fb972cfdb489 SHA512 53a3c9228c13bf25faedd11058413269d26e51209a5f454851aae067679e64ca3897ab78632a620f1f88c8c6407c5b723974d3a6aa4185e7e12b166d55f6559a WHIRLPOOL 16196d2bf09baab0ff68ac7c7f74ce27f409d229cc414b9f62fb1319f5edcebd5e8244453956308c07d3d950fd23195f7606d6bef71e38152b745b0fec6cfd0d
diff --git a/dev-python/sortedcollections/metadata.xml b/dev-python/sortedcollections/metadata.xml
new file mode 100644
index 000000000000..4c79be884169
--- /dev/null
+++ b/dev-python/sortedcollections/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Pure python sorted collection library.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">sortedcollections</remote-id>
+ <remote-id type="github">grantjenks/sortedcollections</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sortedcollections/sortedcollections-0.4.2.ebuild b/dev-python/sortedcollections/sortedcollections-0.4.2.ebuild
new file mode 100644
index 000000000000..aafd52f890a6
--- /dev/null
+++ b/dev-python/sortedcollections/sortedcollections-0.4.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to sort collections and containers"
+HOMEPAGE="http://www.grantjenks.com/docs/sortedcontainers/"
+SRC_URI="mirror://pypi/$(echo ${PN} | cut -c 1)/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/sortedcontainers[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die
+}