summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-23 03:05:20 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-23 04:11:25 +0200
commitf37e52fec34a70b6137f7c225a7da488d7fac2b4 (patch)
tree9438a541c17d2b9ea4dfd745ec320d7b89cc6c8c /dev-python
parentdev-python/botocore: Bump to 1.34.111 (diff)
downloadgentoo-f37e52fec34a70b6137f7c225a7da488d7fac2b4.tar.gz
gentoo-f37e52fec34a70b6137f7c225a7da488d7fac2b4.tar.bz2
gentoo-f37e52fec34a70b6137f7c225a7da488d7fac2b4.zip
dev-python/boto3: Bump to 1.34.111
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.111.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index f56402a4943e..60bf65056572 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,4 +3,5 @@ DIST boto3-1.34.107.gh.tar.gz 809164 BLAKE2B ab11e6bd87ee2fa473e95fc1a135b90769f
DIST boto3-1.34.108.gh.tar.gz 809808 BLAKE2B 56d21fdc35917426ea94f27ee4c7a59bc9eb8b265bdd6366216df090e25e834a7045cc26559b4773a12771a825054462552a44a701acabf2ba662aae9aee1f90 SHA512 d286bb99b838469b8f467f54fcebba4f3712fd1247cda227ba42dab2690ddc937368edcf54452b1ea555d19c9e0f8852c7ac01f0a3612b0592b16e97abbb6697
DIST boto3-1.34.109.gh.tar.gz 810229 BLAKE2B 7d0af8783283715d281df2e68284aa98ead02c764892ec53bdff5212b470c561da4a52b94c62936a20d36a1bd32dac560a38e59577b34d9f82bbee197491e94b SHA512 f35cfb8cbab03c0c6856c01f095cf593c188ab81c8f9bd9c7f9d4e3ca654204795d19810ed701d31ee48f0a34ae1d47437b64ea5f7090708976e7d883677440f
DIST boto3-1.34.110.gh.tar.gz 811067 BLAKE2B 5c030d0a52081a2e931c85611b510558c79a3079d3aa445b82bf2421424c00076f6f0d415dbec838cd437e680470652245595ec8a83e835eba3480f147f12a45 SHA512 e0780b1cca01503d730f01423cbab369cc0c4de8fd2e59033e64779d41c3d648aa54a8b80b6997d1ad9f2bab2673e426a3c1b5bf6536fb0f4248b0c7eade8512
+DIST boto3-1.34.111.gh.tar.gz 811593 BLAKE2B 5b1ba72259c6cf995e4a3668e6b4e195e9bfcfa6b3b0fb992795f98da301c1982196e3af1adfda355a4b73fb418158bc737524e8d220303af3c3fd28c65e2ff0 SHA512 7d0735a6beb3ba7d3e2c4eba4023d5f291aa522c1ea3947c37f29ae235e69ac02847bda7c4e9cd694d6e89fe3bf0e56b1cd41a4fed40b8924670b240c8643f98
DIST boto3-1.34.98.gh.tar.gz 805719 BLAKE2B 5cf7f0cc415e25c8b41aa464b636b1683f4e71198569f5eac3e6e43cef7050e20e92c3fd988517fc1463601073b41b0b9c668a58bb866d03b83973c9b9cd976a SHA512 06cab81bbf73a9c37b68e0312a7c587bace700b8032e283b6782c1275804ea7c93065c4282837957b5cf3523d50fe57319a54af494262e2666f65440da9771fd
diff --git a/dev-python/boto3/boto3-1.34.111.ebuild b/dev-python/boto3/boto3-1.34.111.ebuild
new file mode 100644
index 000000000000..2c733040b7a3
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.111.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}