summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-21 21:45:36 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-21 21:47:37 +0100
commitd0a29d41ac23b636147912ba921e38609759ad58 (patch)
tree47fd533e0df3740bd80194bfad6a0b3070f70a96 /dev-python
parentdev-lang/kotlin-bin: new package; add 1.9.22 (diff)
downloadgentoo-d0a29d41ac23b636147912ba921e38609759ad58.tar.gz
gentoo-d0a29d41ac23b636147912ba921e38609759ad58.tar.bz2
gentoo-d0a29d41ac23b636147912ba921e38609759ad58.zip
dev-python/ytmusicapi: bump to 1.5.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ytmusicapi/Manifest1
-rw-r--r--dev-python/ytmusicapi/ytmusicapi-1.5.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/ytmusicapi/Manifest b/dev-python/ytmusicapi/Manifest
index ee26d52b5f07..8dea0dceaaf2 100644
--- a/dev-python/ytmusicapi/Manifest
+++ b/dev-python/ytmusicapi/Manifest
@@ -1,2 +1,3 @@
DIST ytmusicapi-1.3.2.tar.gz 71732 BLAKE2B 957c2b88ea2c9e59c81401762e4dfd4a52a2f5d3ba59653d2556c3d29225ab4bd92155070e75812f302430b453a5c32a2f44fb508b24905a8f0d16c6fe51299b SHA512 c9ccf7999d668502549e4b5393682192d1db2851660444b6255d5bfb2c0c994ab4715800b669bf57d60866aef7c5529ece374c1eda8d945c7008477438dd0fdd
DIST ytmusicapi-1.4.2.tar.gz 97077 BLAKE2B fe54fa253dec464b5112eb209b3b16929d87a93c360aded5d7ddd5598614f3c5a6c53be973a0c209d32b185effba81522fb17bed565511c3d7db0517f2bf5f8f SHA512 2fb87aa287c38fc1c5d6709bbcf0385205d2becdf1067ee7f8e50b57c9b8e974b457ab34039b1477e6890f0fc7e79b6291f4f2945dbde09294bb1f8c4822be3d
+DIST ytmusicapi-1.5.0.tar.gz 101082 BLAKE2B 682936a7e896cfe229945024a24370595f3e1c269bf15476e03224a62bf17ff38aa21ac9c940a7b2c9ab0dca69d51d560ba28d269489bb1bf3a831e384b79c5d SHA512 64fbac9a8600e86b046f210d677ec2b11349bd2ad9859eb0e67ea3c2b4f664e4087dcf51911911e249af957374fffb05997fc9863c1cbeb15958627e62716548
diff --git a/dev-python/ytmusicapi/ytmusicapi-1.5.0.ebuild b/dev-python/ytmusicapi/ytmusicapi-1.5.0.ebuild
new file mode 100644
index 000000000000..1537ab0e5d66
--- /dev/null
+++ b/dev-python/ytmusicapi/ytmusicapi-1.5.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unofficial API for YouTube Music"
+HOMEPAGE="https://ytmusicapi.readthedocs.io/
+ https://github.com/sigma67/ytmusicapi/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx-rtd-theme