summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2016-08-05 14:50:23 +0200
committerDirkjan Ochtman <djc@gentoo.org>2016-08-05 14:50:23 +0200
commitbbe890edaf84e5c93a526d442d91fed33edd8b12 (patch)
tree3ee12c573c906bc48064e26c03c95ed4df830919 /dev-python
parentdev-ruby/rest-client: add 2.0.0 and bin-less 1.8.0-r3 (diff)
downloadgentoo-bbe890edaf84e5c93a526d442d91fed33edd8b12.tar.gz
gentoo-bbe890edaf84e5c93a526d442d91fed33edd8b12.tar.bz2
gentoo-bbe890edaf84e5c93a526d442d91fed33edd8b12.zip
dev-python/couchdb-python: version bump to 1.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/couchdb-python/Manifest1
-rw-r--r--dev-python/couchdb-python/couchdb-python-1.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/couchdb-python/Manifest b/dev-python/couchdb-python/Manifest
index 7fe68f44d856..3abace758fdb 100644
--- a/dev-python/couchdb-python/Manifest
+++ b/dev-python/couchdb-python/Manifest
@@ -1,2 +1,3 @@
DIST CouchDB-1.0.1.tar.gz 57630 SHA256 ed4d9dbb0a8085e709f8ab11e522c7241f58b554a4e900886225c139fa9a47dc SHA512 5c0ffef5ac3743adfb48ce9efd6af42a01d5d68d412f4d58051e627e97cad225f287d3afb7a5879e12a06503a79e6a5dc063acbf02bf613c736fef82241d2a4e WHIRLPOOL 790cc1d2563630c1cc0b8f80e47bca74bac0a16b0782207fafeb12c9351b5bcaf0c1aa2d78b851e4bc9e0f539b3a914901709fca1ed859c6af1cb0a77f178c21
DIST CouchDB-1.0.tar.gz 56791 SHA256 f81de35433932e1d81b922d12119fe9b2435046db5dc53d1fb068a087c1fb264 SHA512 c328a9b027d24ee560ef592925a072a463852fdb7e8e93e1d6e740d7245181ba147985d610d6fd55f4790d7338e69470c44f574469e718eeb7b4163dfb6fc19a WHIRLPOOL 326be4bedd76ebbc5c9fd3cbdc52182230e0701372e75fa074a328633668e407528ccab7d3516b665be8587d131db4e7f7ba054cb6be2fca60b16265793f38c4
+DIST CouchDB-1.1.tar.gz 60839 SHA256 9503ea413956c33b5e2af248235afb5e0f011f33f816a32e872f8ff9b0a0e710 SHA512 f68a0bb04f74cf91ae7d190eedec2a9c24c03dd0ef333c27cca7ef7abc95d3d355f78d653d68371a0d27dcc9a8d69f5886627f0eb0c6af49b632becf6bd0668f WHIRLPOOL 44f51ab1a2f05edd8cf2219ce6fb108d99264f4dd952cf71ae89030fe97c2adf54350ae7352271200be2861e4f1e33a199aa072cebd0e16d9f489b8657470f59
diff --git a/dev-python/couchdb-python/couchdb-python-1.1.ebuild b/dev-python/couchdb-python/couchdb-python-1.1.ebuild
new file mode 100644
index 000000000000..9ff10717fa84
--- /dev/null
+++ b/dev-python/couchdb-python/couchdb-python-1.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+MY_PN="CouchDB"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python library for working with CouchDB"
+HOMEPAGE="https://github.com/djc/couchdb-python https://pypi.python.org/pypi/CouchDB"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+# Tests require connectivity to a couchdb server.
+# Re-enable when the ebuild is capable of starting a local couchdb
+# instance.
+RESTRICT=test
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}