summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-01-20 18:43:04 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-01-20 19:55:27 +0200
commitb69a6ff2d78ebec4342a9fc38ae3c282e3d7e27f (patch)
tree3c56bb9fc6a13d0664f6316b9b9907a2719fc3d7 /dev-python
parentdev-python/zconfig: drop 3.6.0-r1 (diff)
downloadgentoo-b69a6ff2d78ebec4342a9fc38ae3c282e3d7e27f.tar.gz
gentoo-b69a6ff2d78ebec4342a9fc38ae3c282e3d7e27f.tar.bz2
gentoo-b69a6ff2d78ebec4342a9fc38ae3c282e3d7e27f.zip
dev-python/serverfiles: Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/serverfiles/serverfiles-0.3.1-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/serverfiles/serverfiles-0.3.1-r1.ebuild b/dev-python/serverfiles/serverfiles-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..f259777bd2e0
--- /dev/null
+++ b/dev-python/serverfiles/serverfiles-0.3.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+inherit distutils-r1
+
+DESCRIPTION="Utility for accessing HTTP server and storing files locally for reuse"
+HOMEPAGE="https://github.com/biolab/serverfiles"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/requests-2.11.1[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest