summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2022-06-19 18:53:12 +0200
committerLouis Sautier <sbraz@gentoo.org>2022-06-19 18:53:12 +0200
commit907001799716ce909007b8ecb7540c8bf8895efa (patch)
tree510edd1e1e70c1da994deef9faedd93e8900f675 /dev-python
parentsys-apps/usbguard: Make logs go to /var/log not /var/lib/log (diff)
downloadgentoo-907001799716ce909007b8ecb7540c8bf8895efa.tar.gz
gentoo-907001799716ce909007b8ecb7540c8bf8895efa.tar.bz2
gentoo-907001799716ce909007b8ecb7540c8bf8895efa.zip
dev-python/humanize: add 4.2.0
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-4.2.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index cba3b1e01242..56452d90703d 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1 +1,2 @@
DIST humanize-4.1.0.tar.gz 73777 BLAKE2B fcbde90977ae9fcd706e423767b1d5617fd118ae8903283f4b307ee05a5adffb3bb68305e5d758b1860d37a37d22766127d84479d331a7ed05c83cd53e5b0829 SHA512 7e2d92ed44e773bd8a53d4b151e80949fda057d8f4a52003826efa9ec2a569360b76663d44c3d1239fd2ecdd5365357d3fac72a395d1c10d5207b4a27f248878
+DIST humanize-4.2.0.tar.gz 75169 BLAKE2B dc590d296362be20f607282686e18df73e1bb07aa37459431d7ec1f74ff6611497811da974b7eb62cd791536268018460d9171eb65ed958af6f12f668b3ae2a8 SHA512 ac0a067320d4dc236d97a69a3019cf01ce87efe2cb98e758f516f90986352fe87d03bfa497d66a2a75e61152a35fd8fac827bafd926d6bd84c8f0d2366e5beb7
diff --git a/dev-python/humanize/humanize-4.2.0.ebuild b/dev-python/humanize/humanize-4.2.0.ebuild
new file mode 100644
index 000000000000..b471878fc311
--- /dev/null
+++ b/dev-python/humanize/humanize-4.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="
+ https://github.com/python-humanize/humanize/
+ https://pypi.org/project/humanize/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest