summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-31 06:05:14 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-31 06:17:55 +0100
commit280ddb9088bf34692841b899f47328f2e27f3ea7 (patch)
treebb532fa216b60b6017268c2d5b93d87df20352cc /dev-python
parentdev-python/m2crypto: Bump to 0.43.0 (diff)
downloadgentoo-280ddb9088bf34692841b899f47328f2e27f3ea7.tar.gz
gentoo-280ddb9088bf34692841b899f47328f2e27f3ea7.tar.bz2
gentoo-280ddb9088bf34692841b899f47328f2e27f3ea7.zip
dev-python/cfn-lint: Bump to 1.18.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-1.18.3.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index e4431f1cd23b..0471a8233edd 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -4,3 +4,4 @@ DIST cfn_lint-1.16.1.tar.gz 2328621 BLAKE2B 034738d924ac720a1e85569d65afd47c4cf0
DIST cfn_lint-1.17.2.tar.gz 2526962 BLAKE2B 76feefa1bcce6a0957ce028d6041ac49b475cf25bd843e7de30b1d05d797e55d4189d9deba087f569f94f2f8fc40b11c3ecddcab1593432abf0da1bd26db6da9 SHA512 79fa133244cfe1239648209da9e8bbb2e50435bc5c18b6f998c90eb09536a760dfae62507123c22295098bf0866b1ef0ed05853debb00e651b75651921401530
DIST cfn_lint-1.18.1.tar.gz 2553280 BLAKE2B 9dbe580c17a542e21f3d262dc531dff048d9c67bd1d5c04a5545aa0ea9d5169b5b9ed29622a07d15418c706bef39883418762a5e45beee35e19270bfc385e8e7 SHA512 31a800114c8e8f7e469bbc64a43000f63de092532171a419bf4a0c1ceaf6eb76c1c58d741b86d7a762320de2a89bb6796cf52c4d5edb83dcdf88d6a8ef0abbfe
DIST cfn_lint-1.18.2.tar.gz 2742664 BLAKE2B e83933f8b9af6fefef84d9905be35772d7a62eebe86e75e4fae680b39588ec0e11dac418ddd41a7ac9d716a0e62c8e16671240d5d7971520e9d552d6dd1dce41 SHA512 c6eeaa7a7ce847233adcd6edde5166d304870ca01dc5b84bb5b9c5c1730fe820c7c33195ef34a3db581a66a0976b359f8f15a8c4677a8a37b5f11c2d2feea526
+DIST cfn_lint-1.18.3.tar.gz 2768521 BLAKE2B 277d52b6005e175bf87094dc6a0c71e660217db2665a03f1408ed03d67c2b72aefd0d2ed377869932aabeb351449eb6f7e05db3d8abebe94eed18b60d4c9c283 SHA512 27803f683f8f0440b71925a511fd9cd81c8a81c35a04b267a6f67833d40e2d1dca94f9c81bad507ede02c049ef5143372d5e9aa148ea5242b946d1cd3ac55a77
diff --git a/dev-python/cfn-lint/cfn-lint-1.18.3.ebuild b/dev-python/cfn-lint/cfn-lint-1.18.3.ebuild
new file mode 100644
index 000000000000..086f03ea08df
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-1.18.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.91.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ # different graphviz version?
+ test/unit/module/template/test_template.py::TestTemplate::test_build_graph
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}