summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-19 06:01:58 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-19 06:01:58 +0200
commit10becb8e372cef7aec7d1a583893213674e9af3a (patch)
tree89cb83fa29585d91abd7e9d4c0f46b0c92c6cab0 /dev-python
parentdev-python/u-msgpack-python: Bump to 2.8.0 (diff)
downloadgentoo-10becb8e372cef7aec7d1a583893213674e9af3a.tar.gz
gentoo-10becb8e372cef7aec7d1a583893213674e9af3a.tar.bz2
gentoo-10becb8e372cef7aec7d1a583893213674e9af3a.zip
dev-python/apsw: Bump to 3.42.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/apsw/Manifest1
-rw-r--r--dev-python/apsw/apsw-3.42.0.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index 49c4b0bc21fd..58f67da6bff4 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1 +1,2 @@
DIST apsw-3.41.2.0.gh.tar.gz 871995 BLAKE2B 3d6959133cbfe8914eaadb46543a3a65db24b97aef362eb43e90448be34467a2a9e0f651ff67a9b0ce02df2c6eefa5b5e1c599547e72713e2ddbd1ec6c4f558b SHA512 292ea5a84f406fccb3ba5bf229a38d9c35a32f342b7e1065f08b2758c1d0d9b6517d37c32ce625f9e21cc55339eb2eea35da26a0f17d79a1fc58e1d6b08a8570
+DIST apsw-3.42.0.0.gh.tar.gz 863081 BLAKE2B 5eee11867e41c396be7cc9bbde1c4bb82a1e294ddd05613d6fbd50ac95c2d5e374632fde3215a838779253ad0f2eb97a4550771767a9f9f7a53c062c7eee5f7e SHA512 e0afa56d1a1d4e8627fe721c36098182efad23128cb053c7c25fc6412d6fe63a50beb66e0bc8dce527c17ff7bd9adb9e71a35fbc4ee769b5231d4dd941b21572
diff --git a/dev-python/apsw/apsw-3.42.0.0.ebuild b/dev-python/apsw/apsw-3.42.0.0.ebuild
new file mode 100644
index 000000000000..cbe98664d4c3
--- /dev/null
+++ b/dev-python/apsw/apsw-3.42.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%.*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ enable=load_extension
+ use_system_sqlite_config=True
+ EOF
+}
+
+python_test() {
+ esetup.py build_test_extension
+ cd "${T}" || die
+ "${EPYTHON}" -m apsw.tests -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}