summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-05-20 22:04:42 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-05-21 02:51:11 +0200
commit496d462d5d3f0a472822fbea268f9e1cacfbfd96 (patch)
tree692226f86135351e6f38147b70416da272092943 /dev-python/ytmusicapi
parentdev-dotnet/dotnet-outdated: bump to 4.6.2 (diff)
downloadgentoo-496d462d5d3f0a472822fbea268f9e1cacfbfd96.tar.gz
gentoo-496d462d5d3f0a472822fbea268f9e1cacfbfd96.tar.bz2
gentoo-496d462d5d3f0a472822fbea268f9e1cacfbfd96.zip
dev-python/ytmusicapi: bump to 1.7.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-python/ytmusicapi')
-rw-r--r--dev-python/ytmusicapi/Manifest1
-rw-r--r--dev-python/ytmusicapi/ytmusicapi-1.7.2.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/ytmusicapi/Manifest b/dev-python/ytmusicapi/Manifest
index e1e371068795..26d693baded0 100644
--- a/dev-python/ytmusicapi/Manifest
+++ b/dev-python/ytmusicapi/Manifest
@@ -1,3 +1,4 @@
DIST ytmusicapi-1.6.0.tar.gz 106624 BLAKE2B b7900f4fb9e863f694a06a9d85d479e13514d6f4a0ad86e923ccceb497ad9294e34d9b3914005063b272ef8582514a5ea7c173864d38a2b6ec166bcf1199560e SHA512 9886c0b4ec29bf9b676b4c77f9e84ca6c7a0f1b4da264d589aed19d50c8be6ef3718185af755d8a9f652d425ae98603fff09ea8d84ec839756dab43181eb9f4c
DIST ytmusicapi-1.7.0.tar.gz 276068 BLAKE2B 39b33782fde91ada32269e6ec8630164796caff2e17743a852f1eca72debaf23b01fd9e8f4d486e1a67bf790221a233339b0074034d993053388cf31cadb32a0 SHA512 4e5f021e7dc9879e6cf881595afc8c17637e0d722a019b855563358f38bb74fe5ff154ea639c6d56836967c520bfece504733bf960b77cfe79b0586390339551
DIST ytmusicapi-1.7.1.tar.gz 276874 BLAKE2B 0fee5ad7219b675cbd1cf91e7722dc0addfc7f91be7ad8d74e0df99cc770726df68a1e37d47531161323a42115283b8072f87df2e0261c3b14176a005dd4e52b SHA512 1285ca07cfe18e3965cb769c34a507266188e4d5fa3e34f8e29bb69e0a31aab605f25dbdf24c790621cbcbd7552c0b44a0ae8a0be0237971a02f19d58a05b79f
+DIST ytmusicapi-1.7.2.tar.gz 277033 BLAKE2B f81ecedc00a48e2daa777388d8d362aa5bb6cb5c984277e96a0a4fe62aef55b5926f7eac26ec7a6e526db6ee7abbad570a4e71d7544349b51f33bcaa7f5daac4 SHA512 012b904accdb2fd84871909a139b1b665d0266ed2c157d4988ec0a02eb22ca47803ab980af2828442ca83a08c76c4fb88bec4dedcaf3a15b58e9ff1d2b9ee44c
diff --git a/dev-python/ytmusicapi/ytmusicapi-1.7.2.ebuild b/dev-python/ytmusicapi/ytmusicapi-1.7.2.ebuild
new file mode 100644
index 000000000000..1537ab0e5d66
--- /dev/null
+++ b/dev-python/ytmusicapi/ytmusicapi-1.7.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unofficial API for YouTube Music"
+HOMEPAGE="https://ytmusicapi.readthedocs.io/
+ https://github.com/sigma67/ytmusicapi/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx-rtd-theme