summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-21 07:30:14 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-21 11:08:22 +0100
commita09b0ac192400408b69c650482e5c5a84e290438 (patch)
tree43113b14e428311c2137cd2924ca3e81c327a3f0 /dev-python/xmlschema
parentapp-arch/libarchive: Remove redundant versions (diff)
downloadgentoo-a09b0ac192400408b69c650482e5c5a84e290438.tar.gz
gentoo-a09b0ac192400408b69c650482e5c5a84e290438.tar.bz2
gentoo-a09b0ac192400408b69c650482e5c5a84e290438.zip
dev-python/xmlschema: Bump to 1.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema')
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-1.1.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index 35010402e22f..00943158ed22 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1,2 +1,3 @@
DIST xmlschema-1.0.16.tar.gz 278082 BLAKE2B 284f71536f86475fbfccefe1130fbea9319282e34ec11a1ca13c6ddd0f8aad2747d66c8cc6443885982c6f98fa074778f2757d012d1380ae46136dc3e5df4a69 SHA512 5dd79e608036995d70b4da627f89c86cd8e7a66f80c2cb87d701395229daa920759769bf7efad34c33dd28ca14971eb155a654f8fec12fb6ace8cb5ecf979650
DIST xmlschema-1.1.0.tar.gz 285006 BLAKE2B 9369726c6a6680b9a6d9f317ae96df2db68c1cfe8a1024c141bee2211f5ec176898bc147a9597523c872bee6e7519bc9e57972710fe8f983fdeac7ac7984f901 SHA512 6f5e163969ab06a38cf5b36b6b3f6ba31c98753fc5b364e94889b02b5b2c1b2a3bcae8b5c2b809a9c35c1a2cd855f1b98c68723c51ec2b12998db1a4d1c114c9
+DIST xmlschema-1.1.1.tar.gz 293535 BLAKE2B 563552038f4c07b183ac60ba5d477ab68f9dd81f8f2b93733054adb83dc0b7d892f8ea1bd487c1e8404b6d4ee78e258791ddfb6d99cdb8a63501e13fd204969a SHA512 c2acb1b624173f61fa68b022d205183097c652f7d5389277d23a35fb16a2de5db37d4fa36cdaa9af860f4f6117b5d2f8740f541914f65f951ee24659f3fd4611
diff --git a/dev-python/xmlschema/xmlschema-1.1.1.ebuild b/dev-python/xmlschema/xmlschema-1.1.1.ebuild
new file mode 100644
index 000000000000..8ea796fb40b0
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-1.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ =dev-python/elementpath-1.4*[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2)
+ )"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}