summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-20 10:41:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-20 10:41:54 +0200
commit107567f5f1c69703403ca3ae8067e047cd5da1d1 (patch)
tree9cdc6171dfc48b1037c0118ec4608d02c16c625e /dev-python/wxpython
parentdev-python/tinycss2: Remove duplicate SRC_URI (diff)
downloadgentoo-107567f5f1c69703403ca3ae8067e047cd5da1d1.tar.gz
gentoo-107567f5f1c69703403ca3ae8067e047cd5da1d1.tar.bz2
gentoo-107567f5f1c69703403ca3ae8067e047cd5da1d1.zip
dev-python/wxpython: Use pypi.eclass in older version(s)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/wxpython-4.0.7-r4.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/dev-python/wxpython/wxpython-4.0.7-r4.ebuild b/dev-python/wxpython/wxpython-4.0.7-r4.ebuild
index 03f66f04f701..7b34ac3aec81 100644
--- a/dev-python/wxpython/wxpython-4.0.7-r4.ebuild
+++ b/dev-python/wxpython/wxpython-4.0.7-r4.ebuild
@@ -2,19 +2,18 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
-WX_GTK_VER="3.0-gtk3"
DISTUTILS_IN_SOURCE_BUILD="1"
+PYTHON_COMPAT=( python3_{9..10} )
+PYPI_NO_NORMALIZE=1
+PYPI_PN="wxPython"
+WX_GTK_VER="3.0-gtk3"
-inherit distutils-r1 multiprocessing virtualx wxwidgets
-
-MY_PN="wxPython"
-MY_PV="${PV}.post2"
+inherit distutils-r1 multiprocessing virtualx wxwidgets pypi
DESCRIPTION="A blending of the wxWindows C++ class library with Python"
HOMEPAGE="https://www.wxpython.org/"
-SRC_URI="mirror://pypi/${P:0:1}/${MY_PN}/${MY_PN}-${MY_PV}.tar.gz"
+SRC_URI="$(pypi_sdist_url --no-normalize "${PYPI_PN}" "${PV}.post2")"
LICENSE="wxWinLL-3"
SLOT="4.0"
@@ -45,7 +44,7 @@ BDEPEND="${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
)"
-S="${WORKDIR}/${MY_PN}-${MY_PV}"
+S="${WORKDIR}/${PYPI_PN}-${PV}.post2"
PATCHES=(
"${FILESDIR}/${PN}-4.0.6-skip-broken-tests.patch"