summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-29 20:21:13 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-29 21:17:54 +0300
commitfb9f4701f0a6fdfa6497df56a2a83786cdb22240 (patch)
treee618012f170c1058085cbed592b3d5de6abdd1f3 /dev-python/whisper
parentsci-libs/gdal: add 3.3.3 (diff)
downloadgentoo-fb9f4701f0a6fdfa6497df56a2a83786cdb22240.tar.gz
gentoo-fb9f4701f0a6fdfa6497df56a2a83786cdb22240.tar.bz2
gentoo-fb9f4701f0a6fdfa6497df56a2a83786cdb22240.zip
dev-python/whisper: add 1.1.8, EAPI=8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/whisper')
-rw-r--r--dev-python/whisper/Manifest1
-rw-r--r--dev-python/whisper/whisper-1.1.8.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/whisper/Manifest b/dev-python/whisper/Manifest
index 72d9cb837988..1aa2566364bf 100644
--- a/dev-python/whisper/Manifest
+++ b/dev-python/whisper/Manifest
@@ -1 +1,2 @@
DIST whisper-1.1.7.tar.gz 38289 BLAKE2B 05c5ed972c6dbe8ecc29731d206a44e4db2605aa1270d0eba63c90390062f3cee81a6076a571e6b18cc54f8b1a0ffbc9800c91e9aa7cf3cab862d7e6bb8217c0 SHA512 2dc4f15a91b518495da120af4ad2af4b5f81d04fae6028ca1d7505046b93082a9294452a703c8de87dc89629c35dca0809c4ee7c0df1a7a6bd5ec527f3126df2
+DIST whisper-1.1.8.gh.tar.gz 39117 BLAKE2B 591a3529725f300c6d8bab40444bdd41bcfe3d832893e954295d5387e047e2a639db4235131cd90fdb686395d51afccf30f64a52e194e4cd8e00b86e38f841d6 SHA512 0452c684128a750e30e926aee0cfd6c94f129eeb561246f9e1c66d7cf1f27f139df84f91e935237f89d0b4fac98678108568cfb94c2ab4138480f4db31471ab4
diff --git a/dev-python/whisper/whisper-1.1.8.ebuild b/dev-python/whisper/whisper-1.1.8.ebuild
new file mode 100644
index 000000000000..f960a40caf88
--- /dev/null
+++ b/dev-python/whisper/whisper-1.1.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Fixed size round-robin style database"
+HOMEPAGE="https://github.com/graphite-project/whisper"
+# PyPI tarballs don't contain tests
+# https://github.com/graphite-project/whisper/pull/253
+SRC_URI="
+ https://github.com/graphite-project/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests --install pytest