summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-14 17:14:46 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-14 17:55:49 +0100
commitcb0738a21d9e41c19c64f252b921f54619b88c92 (patch)
tree6f3b7d84c234dfdc9686fd7311132eb605a36e06 /dev-python/wheel
parentdev-python/types-gdb: Bump to 12.1.4.4 (diff)
downloadgentoo-cb0738a21d9e41c19c64f252b921f54619b88c92.tar.gz
gentoo-cb0738a21d9e41c19c64f252b921f54619b88c92.tar.bz2
gentoo-cb0738a21d9e41c19c64f252b921f54619b88c92.zip
dev-python/wheel: Bump to 0.40.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wheel')
-rw-r--r--dev-python/wheel/Manifest1
-rw-r--r--dev-python/wheel/wheel-0.40.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/wheel/Manifest b/dev-python/wheel/Manifest
index e1612f697eda..3e16760be045 100644
--- a/dev-python/wheel/Manifest
+++ b/dev-python/wheel/Manifest
@@ -1 +1,2 @@
DIST wheel-0.38.4.gh.tar.gz 69770 BLAKE2B a6077e38c21626169d68a3256fbe6457de3d4fde5d0a582859fe7b9ec5d73c142538f7fbfe762ddd436473c682e7810407a08730f66ec2a7844084d349e0779f SHA512 2ff7c6175201f8145f2c1f9937c6955a1dd22eeedab1e456f65c4edae9186610d9e7702c35773b49026c56c9cc201672025e7d42fcc7f782153c65c28e6b90d0
+DIST wheel-0.40.0.tar.gz 96226 BLAKE2B f4207ab822f037a3d8decc50643ad7e49a632028c712bc33c680d178f10117ff0aa4f2a971bf739a77a76dbf818360d0f628ce997b942ee9d85ec7fac28badc8 SHA512 211e68d927c93b9b2748bf081097d1172cf8d4863d540be72f1d6023b64042410805d4208a2c94de89a1eeb0fb32044e78f41ab58ac94498ac0c489a1eea0d23
diff --git a/dev-python/wheel/wheel-0.40.0.ebuild b/dev-python/wheel/wheel-0.40.0.ebuild
new file mode 100644
index 000000000000..1100190f6e16
--- /dev/null
+++ b/dev-python/wheel/wheel-0.40.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A built-package format for Python"
+HOMEPAGE="
+ https://github.com/pypa/wheel/
+ https://pypi.org/project/wheel/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unbundle packaging
+ rm -r src/wheel/vendored || die
+ sed -i -e 's:\.vendored\.::' src/wheel/*.py || die
+ sed -i -e 's:wheel\.vendored\.::' tests/*.py || die
+
+ distutils-r1_src_prepare
+}