summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-08 12:10:12 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-08 13:09:46 +0200
commit2830e9eafb13cd2c2b2820a07a3e6a0f51d32e8d (patch)
treef8bef56edb5c04e28e7cf88dbf5017d02b8aa36e /dev-python/websockets
parentmail-mta/postfix: add 3.8_pre20220407, drop 3.8_pre20220403 (diff)
downloadgentoo-2830e9eafb13cd2c2b2820a07a3e6a0f51d32e8d.tar.gz
gentoo-2830e9eafb13cd2c2b2820a07a3e6a0f51d32e8d.tar.bz2
gentoo-2830e9eafb13cd2c2b2820a07a3e6a0f51d32e8d.zip
dev-python/websockets: Switch to pytest for easier deselects
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/websockets')
-rw-r--r--dev-python/websockets/websockets-10.2.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/dev-python/websockets/websockets-10.2.ebuild b/dev-python/websockets/websockets-10.2.ebuild
index e43c8d5084ee..729159c20d01 100644
--- a/dev-python/websockets/websockets-10.2.ebuild
+++ b/dev-python/websockets/websockets-10.2.ebuild
@@ -18,12 +18,8 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv sparc x86"
-distutils_enable_tests unittest
+distutils_enable_tests pytest
-src_prepare() {
- # these fail due to timeouts on slower hardware
- sed -e 's:test_keepalive_ping_with_no_ping_timeout:_&:' \
- -e 's:test_keepalive_ping(:_&:' \
- -i tests/legacy/test_protocol.py || die
- distutils-r1_src_prepare
+python_test() {
+ epytest tests
}