summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-04-24 10:02:27 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-04-24 10:02:27 -0500
commitfb38b143d0872d1455498944e01e3dfead6d7858 (patch)
tree029c42625964791cdf28c6fbba1688784ca00b87 /dev-python/websocket-client/websocket-client-0.37.0.ebuild
parentdev-libs/protobuf-c: DESCRIPTION fixed to satisfy RepoMan (diff)
downloadgentoo-fb38b143d0872d1455498944e01e3dfead6d7858.tar.gz
gentoo-fb38b143d0872d1455498944e01e3dfead6d7858.tar.bz2
gentoo-fb38b143d0872d1455498944e01e3dfead6d7858.zip
dev-python/websocket-client: add version 0.37.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/websocket-client/websocket-client-0.37.0.ebuild')
-rw-r--r--dev-python/websocket-client/websocket-client-0.37.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/websocket-client/websocket-client-0.37.0.ebuild b/dev-python/websocket-client/websocket-client-0.37.0.ebuild
new file mode 100644
index 000000000000..0078df108716
--- /dev/null
+++ b/dev-python/websocket-client/websocket-client-0.37.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN//-/_}
+
+DESCRIPTION="WebSocket client for python with hybi13 support"
+HOMEPAGE="https://github.com/liris/websocket-client"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]' 'python2*' )
+"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}