summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-04-08 12:52:39 +0200
committerSebastian Pipping <sping@gentoo.org>2020-04-08 12:52:39 +0200
commit09fd59cb65d432d973ab9319b8aa6fb6c38a8abf (patch)
tree898f9e6ec882217b3d8db410228d805f3e8617a6 /dev-python/wcwidth
parentnet-dns/avahi: arm stable wrt bug #714630 (diff)
downloadgentoo-09fd59cb65d432d973ab9319b8aa6fb6c38a8abf.tar.gz
gentoo-09fd59cb65d432d973ab9319b8aa6fb6c38a8abf.tar.bz2
gentoo-09fd59cb65d432d973ab9319b8aa6fb6c38a8abf.zip
dev-python/wcwidth: 0.1.9
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.92, Repoman-2.3.22
Diffstat (limited to 'dev-python/wcwidth')
-rw-r--r--dev-python/wcwidth/Manifest1
-rw-r--r--dev-python/wcwidth/wcwidth-0.1.9.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/wcwidth/Manifest b/dev-python/wcwidth/Manifest
index 16f14e2c9e2c..5bec98c2b580 100644
--- a/dev-python/wcwidth/Manifest
+++ b/dev-python/wcwidth/Manifest
@@ -1 +1,2 @@
DIST wcwidth-0.1.8.tar.gz 19957 BLAKE2B dd4ba31bec5161a9509b0ef7e73901c3ff31b2ceedb3d05eeaf85f90c1157e21d00ee8cd0f715098bf65e5d699a40287ce08e235f2f1d22a73f6606f490a921d SHA512 b828450feb56b5c0e686f6922e777ab48d1336816a41ef4ef95f71c25a37ef492861634c16c788e1e4570d21bd4d45c990a18787860ba6043157c2781c78b65e
+DIST wcwidth-0.1.9.tar.gz 24764 BLAKE2B c7a5a50a8628649810dddd37b1af4c7ea52b2d0d2e516bd24e04675849e6f402e6ef4b7cea0fb507c5446b455d8725f497771bb30cd4d7eafa90cbb6fc2d01b4 SHA512 3aee69efb8714f4426bfd424b80f4f4e5758174d84f725dd0e1448de1b4b4dd385ffd4f72440d5f763b7a82325857e9164742dbb7fa9e15d5db54744c262d0ba
diff --git a/dev-python/wcwidth/wcwidth-0.1.9.ebuild b/dev-python/wcwidth/wcwidth-0.1.9.ebuild
new file mode 100644
index 000000000000..b4fe043cedd8
--- /dev/null
+++ b/dev-python/wcwidth/wcwidth-0.1.9.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
+HOMEPAGE="https://pypi.org/project/wcwidth/ https://github.com/jquast/wcwidth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest