summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-15 06:34:42 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-15 09:00:06 +0200
commit440f6ab17af61eb6ee79f79adc33a050cd0b319e (patch)
tree1b08bc77286e0760fce90925e0950fb1342cfaa1 /dev-python/trimesh
parentdev-python/hypothesis: Bump to 6.115.2 (diff)
downloadgentoo-440f6ab17af61eb6ee79f79adc33a050cd0b319e.tar.gz
gentoo-440f6ab17af61eb6ee79f79adc33a050cd0b319e.tar.bz2
gentoo-440f6ab17af61eb6ee79f79adc33a050cd0b319e.zip
dev-python/trimesh: Bump to 4.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-4.5.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index c1cd5af1529f..649ced29e128 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1 +1,2 @@
DIST trimesh-4.4.9.gh.tar.gz 13612220 BLAKE2B 9ee21f8a3f0db041133b2843948a00e8ee6bf52e3de1d2ca9ac88391ef1c07a4b540c75b439da3e137923f0822399cdf759072729363253ad8137a06cb208791 SHA512 3b58a0378231dd1111ac4ffe030b1dd18d24647e22fe815bc411a7854f83e12a9482cb0b48d5333be9f6f6ebf622c15e29c446531ce27ff12c1835a6f25cc51a
+DIST trimesh-4.5.0.gh.tar.gz 13615659 BLAKE2B 4355e3577084f0b2fbb60efd09e4278c839a76e7e0980528d2b0456f7d72c1a2764ecdc3b5f6969489d280f81a8dd5bfd04c758c4682b816774ce13289ccc8a3 SHA512 a3402e736698dc8b6a78a94742d8256874d7f7f9fecd4e8cdf045f50aea452dfa8e960e3d1d9c773db87eb39b226c41d4ffefbf67f5ab93f85ccf98062a8df54
diff --git a/dev-python/trimesh/trimesh-4.5.0.ebuild b/dev-python/trimesh/trimesh-4.5.0.ebuild
new file mode 100644
index 000000000000..7b71b21dd4d0
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.5.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ dev-python/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mapbox-earcut[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_TIMEOUT=1800
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires manifold3d
+ tests/test_boolean.py::test_multiple_difference
+ )
+ local EPYTEST_IGNORE=(
+ # require pyinstrument
+ tests/test_sweep.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox-earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" dev-python/scikit-image
+}