summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/traitsui
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/traitsui')
-rw-r--r--dev-python/traitsui/Manifest1
-rw-r--r--dev-python/traitsui/files/traitsui-4.3.0-tests.patch34
-rw-r--r--dev-python/traitsui/metadata.xml16
-rw-r--r--dev-python/traitsui/traitsui-4.4.0.ebuild36
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/traitsui/Manifest b/dev-python/traitsui/Manifest
new file mode 100644
index 000000000000..4ca126957012
--- /dev/null
+++ b/dev-python/traitsui/Manifest
@@ -0,0 +1 @@
+DIST traitsui-4.4.0.tar.gz 598148 SHA256 68a10c4f86cf0f5ba5d9fac5caece73e0a76256a4175efcded5edec03949cf60 SHA512 bd563330aa80acbf4087b54f42ffb94856495cf82da8b9c5ae54bdcda2d2544e4293a427ed3b28de7622c2fe063cd14f969b894735eb81cb4932cc3e2ad27bef WHIRLPOOL f49f6278d1b9ec0cc35af5f5f8b695c34082fd3ae8acdc0990634b15305d09b5f975f8906e568ca8ca25a746822c1d11c0c2c7933ad429856ec614fad51c84b6
diff --git a/dev-python/traitsui/files/traitsui-4.3.0-tests.patch b/dev-python/traitsui/files/traitsui-4.3.0-tests.patch
new file mode 100644
index 000000000000..2712203dfb57
--- /dev/null
+++ b/dev-python/traitsui/files/traitsui-4.3.0-tests.patch
@@ -0,0 +1,34 @@
+https://github.com/enthought/traitsui/issues/74
+diff -ur traitsui-4.3.0.orig/traitsui/qt4/ui_panel.py traitsui-4.3.0/traitsui/qt4/ui_panel.py
+--- traitsui/qt4/ui_panel.py 2013-03-29 04:08:54.000000000 +0800
++++ traitsui/qt4/ui_panel.py 2013-04-12 13:23:09.499989912 +0800
+@@ -977,7 +977,7 @@
+
+ if (label is not None
+ and not is_label_left
+- and item_policy == QtGui.QSizePolicy.Policy.Minimum):
++ and item_policy == QtGui.QSizePolicy.Minimum):
+ # this item cannot be stretched horizontally, and the label
+ # exists and is on the right -> make label stretchable if necessary
+
+@@ -1012,7 +1012,7 @@
+ label_policy = label.sizePolicy()
+ label_policy.setHorizontalStretch(stretch)
+ label_policy.setHorizontalPolicy(
+- QtGui.QSizePolicy.Policy.Expanding)
++ QtGui.QSizePolicy.Expanding)
+ label.setSizePolicy(label_policy)
+
+
+diff -ur traitsui-4.3.0.orig/traitsui/tests/_tools.py traitsui-4.3.0/traitsui/tests/_tools.py
+--- traitsui/tests/_tools.py 2013-03-29 04:08:54.000000000 +0800
++++ traitsui/tests/_tools.py 2013-04-12 13:23:09.502989914 +0800
+@@ -173,7 +173,7 @@
+ return ui_control.GetSizeTuple()
+
+ elif is_current_backend_qt4():
+- return ui_control.size().toTuple()
++ return ui_control.size().width(), ui_control.size().height()
+
+
+ # ######### Debug tools
diff --git a/dev-python/traitsui/metadata.xml b/dev-python/traitsui/metadata.xml
new file mode 100644
index 000000000000..89dc0b657609
--- /dev/null
+++ b/dev-python/traitsui/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ The traitsui project contains a toolkit-independent GUI abstraction
+ layer, which is used to support the "visualization" features of the
+ Traits package. Thus, you can write code in terms of the Traits API
+ (views, items, editors, etc.), and let traitsui and your selected
+ toolkit and back-end take care of the details of displaying them.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">traitsui</remote-id>
+ <remote-id type="github">enthought/traitsui</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/traitsui/traitsui-4.4.0.ebuild b/dev-python/traitsui/traitsui-4.4.0.ebuild
new file mode 100644
index 000000000000..b55644f4c1c5
--- /dev/null
+++ b/dev-python/traitsui/traitsui-4.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Traits-capable user interfaces"
+HOMEPAGE="https://github.com/enthought/traitsui"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyface[${PYTHON_USEDEP}]
+ dev-python/traits[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+python_test() {
+ export ETS_TOOLKIT=qt4
+ export QT_API=pyqt
+ VIRTUALX_COMMAND="nosetests -v" virtualmake
+
+}