summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-11 21:07:35 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-11 21:12:47 +0100
commit4065261c05e8f41a96aba84027fbe99a155af16c (patch)
tree8b8772fefba016fa760b16b4874755a8b82028b2 /dev-python/toposort
parentdev-python/urllib3: Bump to 1.26.14 (diff)
downloadgentoo-4065261c05e8f41a96aba84027fbe99a155af16c.tar.gz
gentoo-4065261c05e8f41a96aba84027fbe99a155af16c.tar.bz2
gentoo-4065261c05e8f41a96aba84027fbe99a155af16c.zip
dev-python/toposort: Bump to 1.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/toposort')
-rw-r--r--dev-python/toposort/Manifest1
-rw-r--r--dev-python/toposort/toposort-1.9.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/toposort/Manifest b/dev-python/toposort/Manifest
index 771cacee77bc..f437f0e60cbe 100644
--- a/dev-python/toposort/Manifest
+++ b/dev-python/toposort/Manifest
@@ -1,2 +1,3 @@
DIST toposort-1.7.tar.gz 10671 BLAKE2B 89da22e803c334cec77d5ac8ad6a9ab8013f7516555c2822bd6d511edf28230c85c2eaeabad3dc4a24a58ae3ce3850d407ad957d0e28491574557140a286843a SHA512 a585d1c103b2162fa3f37f6b0ef60a8709f08d9543d7fab619af3718bf9f752a293e50061d370fd08872b2d8a8db504cb9d9c1cce5446885b46fe8e833813833
DIST toposort-1.8.tar.gz 10688 BLAKE2B 354070b8d723a5d75e1c4050b91268d8d747f1d345be58315914b8c3caf9ce0f975a64f281e336952f7e507269b14d4c1c6310b5c7702e0066b25b2f3caab1ed SHA512 f567e371d1524dc6c285a1a25780b92a8052f3c80b8207fbb8d7a5396fb7434ea503e3fac2755443ed52d9383185d2d0f89e18db011ba8b48f2cd013b552f29a
+DIST toposort-1.9.tar.gz 10878 BLAKE2B fc2f6543ae74ea6e448ffe2be4e47438842b5ba95eac2f45fcc8d72e682054af0b80a0d453c5afaebeb1c9881d6874ab16ea523b19aad589545c8aae0b8cf255 SHA512 ec86f59f5e61b6d1c783965095f71693306a83a8b54a0661cddb3c51a5e2f9314075b453a901b5e3664b77d9e047901120622dbc23d642269a9546f41395388a
diff --git a/dev-python/toposort/toposort-1.9.ebuild b/dev-python/toposort/toposort-1.9.ebuild
new file mode 100644
index 000000000000..93680abc0927
--- /dev/null
+++ b/dev-python/toposort/toposort-1.9.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements a topological sort algorithm"
+HOMEPAGE="
+ https://gitlab.com/ericvsmith/toposort/
+ https://pypi.org/project/toposort/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" test/test_toposort.py -v || die "Tests failed with ${EPYTHON}"
+}