summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-05 06:30:41 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-05 13:48:28 +0200
commita10f241a31804a6500f42ff62b1a67294ef3be73 (patch)
tree30bd3d2d4e7a73add10f35ea496ee5f3ea8ca66e /dev-python/tokenize-rt
parentdev-python/aiohttp: Bump to 3.10.1 (diff)
downloadgentoo-a10f241a31804a6500f42ff62b1a67294ef3be73.tar.gz
gentoo-a10f241a31804a6500f42ff62b1a67294ef3be73.tar.bz2
gentoo-a10f241a31804a6500f42ff62b1a67294ef3be73.zip
dev-python/tokenize-rt: Bump to 6.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tokenize-rt')
-rw-r--r--dev-python/tokenize-rt/Manifest1
-rw-r--r--dev-python/tokenize-rt/tokenize-rt-6.0.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/tokenize-rt/Manifest b/dev-python/tokenize-rt/Manifest
index 3477fdb114de..b3d0c155191a 100644
--- a/dev-python/tokenize-rt/Manifest
+++ b/dev-python/tokenize-rt/Manifest
@@ -1 +1,2 @@
DIST tokenize-rt-5.2.0.gh.tar.gz 7239 BLAKE2B a81251b6b8b336a6b1b1095e0b31456e834196fc2174958299ac293e5fc979dcdd2b4fc9c7e2e231e73fd09e116d0538dadf9436b4efdcf1390b2db9a025a4b8 SHA512 4288d474dfa260dea710bfbf529c722215bf8883360d281f41a456c79d4aa029bff9fa22a89e11d83c4095a43738f0751416a53c7e116a484a32937b58c20ff1
+DIST tokenize-rt-6.0.0.gh.tar.gz 7509 BLAKE2B e652a394062fa9965e525430e021a36c9411848dcc1e7283d64692cb349eb5714fd8bce6db0098cd01461a75e638141a18a918befee80a01764ba9d152d1d1da SHA512 40a98a2a6090afa095b4933c63e4ac9dd5b4643a1e804f9ec31956cfc1cff0100a884d62c52c4c769a5810e72ab83b62f5c76cb030e48eced67670b408429cd0
diff --git a/dev-python/tokenize-rt/tokenize-rt-6.0.0.ebuild b/dev-python/tokenize-rt/tokenize-rt-6.0.0.ebuild
new file mode 100644
index 000000000000..f234745b1e29
--- /dev/null
+++ b/dev-python/tokenize-rt/tokenize-rt-6.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around the stdlib 'tokenize' which roundtrips"
+HOMEPAGE="
+ https://github.com/asottile/tokenize-rt/
+ https://pypi.org/project/tokenize-rt/
+"
+SRC_URI="
+ https://github.com/asottile/tokenize-rt/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest