summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-31 09:17:18 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-31 09:18:57 +0200
commitf83b64ea4cc1dca23fbd090b870a41f477de669e (patch)
treea39926856bd0e3bb409072c0a492e230646ee86b /dev-python/thunarx-python
parentxfce-extra/xfce4-panel-profiles: Enable py3.10 (diff)
downloadgentoo-f83b64ea4cc1dca23fbd090b870a41f477de669e.tar.gz
gentoo-f83b64ea4cc1dca23fbd090b870a41f477de669e.tar.bz2
gentoo-f83b64ea4cc1dca23fbd090b870a41f477de669e.zip
dev-python/thunarx-python: Enable py3.10
Closes: https://bugs.gentoo.org/845900 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/thunarx-python')
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.5.2.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/dev-python/thunarx-python/thunarx-python-0.5.2.ebuild b/dev-python/thunarx-python/thunarx-python-0.5.2.ebuild
index e6c360683a7f..20f6bac54822 100644
--- a/dev-python/thunarx-python/thunarx-python-0.5.2.ebuild
+++ b/dev-python/thunarx-python/thunarx-python-0.5.2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
+
+PYTHON_COMPAT=( python3_{8..10} )
inherit python-single-r1
@@ -13,18 +14,23 @@ SRC_URI="https://archive.xfce.org/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
+ ${PYTHON_DEPS}
>=dev-libs/glib-2.30:2
>=x11-libs/gtk+-3.20:3
>=xfce-base/thunar-1.7.0
$(python_gen_cond_dep '
>=dev-python/pygobject-3.20:3[${PYTHON_USEDEP}]
- ')"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
+ ')
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
src_install() {
default