summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-12-24 09:58:45 +0100
committerFabian Groffen <grobian@gentoo.org>2020-12-24 09:58:45 +0100
commit25eda03e3a6f32f3e20742165a0b9e6e6f87f4c2 (patch)
tree53cc3b541c8ba3de1298b59eb6b08c411ecf3b49 /dev-python/thrift
parentwww-apps/baikal: version bump 0.7.2, address PHP8 json default (diff)
downloadgentoo-25eda03e3a6f32f3e20742165a0b9e6e6f87f4c2.tar.gz
gentoo-25eda03e3a6f32f3e20742165a0b9e6e6f87f4c2.tar.bz2
gentoo-25eda03e3a6f32f3e20742165a0b9e6e6f87f4c2.zip
dev-python/thrift-0.13.0: version bump, bug #761409
Bug: https://bugs.gentoo.org/761409 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-python/thrift')
-rw-r--r--dev-python/thrift/Manifest1
-rw-r--r--dev-python/thrift/thrift-0.13.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/thrift/Manifest b/dev-python/thrift/Manifest
index 1294d7e40874..fce62f8684ff 100644
--- a/dev-python/thrift/Manifest
+++ b/dev-python/thrift/Manifest
@@ -1 +1,2 @@
DIST thrift-0.11.0.tar.gz 52467 BLAKE2B 72dca118476dc5d618f6434614e5d72c6f496088731de9b62fcf47e76dcf707a171721df2aa4c87fdcf90670b8fd11c3a1cdb2b090b78683a3f4a204ef8121cb SHA512 cba59eef2841fa008a19cd36b322491b67d711698205d6671c76e38a3de2b330db8aa54516de8cdd4020dc795e67ed55913df53466f5dbf07d38fed2d10f9349
+DIST thrift-0.13.0.tar.gz 59911 BLAKE2B b45363c2e8bbc5c7fae25533c7df9be49e6ea88b5ce077e9a580c28decf06de608d50100ba77cdb1ce8c7e56b87608d193b8579a4f89cc4fb74d672da0ba7e93 SHA512 063440db324efdae1fc4466133deaedeb1edd2f953f6924191ad819476f7b62a434d52960837e94516a673063ceab8b446b4f7dc8c94bb2d1fb84e95d2fa3d78
diff --git a/dev-python/thrift/thrift-0.13.0.ebuild b/dev-python/thrift/thrift-0.13.0.ebuild
new file mode 100644
index 000000000000..7845b01a7354
--- /dev/null
+++ b/dev-python/thrift/thrift-0.13.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of Thrift"
+HOMEPAGE="https://pypi.org/project/thrift/ https://thrift.apache.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}
+