summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2018-10-02 22:39:48 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-19 09:03:56 +0200
commita27c87e27b8e09dd5f4578b382a52fc12465d2f7 (patch)
treefa565eab384012273436728cb7ab7d4ebb7c5f05 /dev-python/svg-path/svg-path-3.0.ebuild
parentnet-libs/libssh2: fix Prefix install, thanks Olivier Huber (diff)
downloadgentoo-a27c87e27b8e09dd5f4578b382a52fc12465d2f7.tar.gz
gentoo-a27c87e27b8e09dd5f4578b382a52fc12465d2f7.tar.bz2
gentoo-a27c87e27b8e09dd5f4578b382a52fc12465d2f7.zip
dev-python/svg-path: new package
Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Horea Christian <horea.christ@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10048 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/svg-path/svg-path-3.0.ebuild')
-rw-r--r--dev-python/svg-path/svg-path-3.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/svg-path/svg-path-3.0.ebuild b/dev-python/svg-path/svg-path-3.0.ebuild
new file mode 100644
index 000000000000..7856e4825787
--- /dev/null
+++ b/dev-python/svg-path/svg-path-3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="svg.path"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="SVG path objects and parser"
+HOMEPAGE="https://github.com/regebro/svg.path"
+SRC_URI="https://github.com/regebro/svg.path/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ esetup.py test || die
+}
+
+python_install() {
+ python_domodule src/svg
+}