summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-17 11:35:08 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-17 11:35:08 +0200
commit94a1a587121898866aede182b4e432472d1fa4c2 (patch)
treede18f60bd356defcc3467cd98d9cae8e4081b5e1 /dev-python/subprocess-tee
parentdev-python/stestr: Remove old (diff)
downloadgentoo-94a1a587121898866aede182b4e432472d1fa4c2.tar.gz
gentoo-94a1a587121898866aede182b4e432472d1fa4c2.tar.bz2
gentoo-94a1a587121898866aede182b4e432472d1fa4c2.zip
dev-python/subprocess-tee: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/subprocess-tee')
-rw-r--r--dev-python/subprocess-tee/Manifest2
-rw-r--r--dev-python/subprocess-tee/subprocess-tee-0.3.2.ebuild36
-rw-r--r--dev-python/subprocess-tee/subprocess-tee-0.3.4.ebuild44
3 files changed, 0 insertions, 82 deletions
diff --git a/dev-python/subprocess-tee/Manifest b/dev-python/subprocess-tee/Manifest
index 0a0e19605508..34f583554fcf 100644
--- a/dev-python/subprocess-tee/Manifest
+++ b/dev-python/subprocess-tee/Manifest
@@ -1,3 +1 @@
-DIST subprocess-tee-0.3.2.tar.gz 14975 BLAKE2B 3198832f4c8bbf90e83038e39017cff1efc61ede84aded8220214e388a088777bdb861c044cddbf4b07c7b3172f8164e8bbf82b33de68d1fefea0f81bbacdfc9 SHA512 e681abc27623a3e05031bc05dc15e34f82c9cb544cd16742855411a9edb11fe8e38f9d11f8e651681d04081f121a47c38ebd172d70d282c8110a62699ef687d6
-DIST subprocess-tee-0.3.4.tar.gz 16013 BLAKE2B 6a98caa111a73ef7062f26796dd3e919d05103ae4de88e2c5ce3acc04d9fbde6b31e39a1cee1984fd8d59b8168ab33faf7ff15c916d52a226ff2cb760fd8c796 SHA512 6a97ddc75b7e7954bb7f5f3bf05807e8dd892869cc13e60344c5f40363bdff4ec5441f829cfbcb8c3c4ab7f7b2697c0b1d4a871be8164acd7cfb6fea5032ae4b
DIST subprocess-tee-0.3.5.tar.gz 16887 BLAKE2B 6eb25085eb2b2ee4557efd556d8035ab8f6b781b47783f24f227db04b3f82fffcfa29d69f0e3588c3fa6188446a3d96d4421e6b1ea5b3292f42635e19a404bab SHA512 47de075e7b6c75598dac0ad1899e1cce9dc1131b49c35ccade2b67c8d2a2d0248ce22a20c336519ff00bfd57269613bc663012e48cf0afa087c93ee74e18e4d4
diff --git a/dev-python/subprocess-tee/subprocess-tee-0.3.2.ebuild b/dev-python/subprocess-tee/subprocess-tee-0.3.2.ebuild
deleted file mode 100644
index 6fe160cd6d1f..000000000000
--- a/dev-python/subprocess-tee/subprocess-tee-0.3.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="subprocess.run replacement with tee(1)-like output"
-HOMEPAGE="https://github.com/pycontribs/subprocess-tee"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep '
- dev-python/enrich[${PYTHON_USEDEP}]
- ' python3_{8,9})
- )"
-
-distutils_enable_tests pytest
-
-# dev-python/{,en}rich ebuilds do not support python3_10 yet
-# We test fine (modulo some deprecation warnings) against 3.10 under tox, though.
-python_test() {
- if [[ ${EPYTHON} == "python3.10" ]]; then
- ewarn "Skipping tests for ${EPYTHON} due to missing dependencies"
- return 0
- fi
- distutils-r1_python_test
-}
diff --git a/dev-python/subprocess-tee/subprocess-tee-0.3.4.ebuild b/dev-python/subprocess-tee/subprocess-tee-0.3.4.ebuild
deleted file mode 100644
index c17411cbabe9..000000000000
--- a/dev-python/subprocess-tee/subprocess-tee-0.3.4.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="subprocess.run replacement with tee(1)-like output"
-HOMEPAGE="https://github.com/pycontribs/subprocess-tee"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test-full"
-
-REQUIRED_USE="test-full? ( test )"
-
-# ansible-molecule is invoked as an executable so no need for PYTHON_USEDEP
-BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep '
- dev-python/enrich[${PYTHON_USEDEP}]
- ' python3_{8,9})
- test-full? ( app-admin/ansible-molecule )
- )"
-
-distutils_enable_tests pytest
-
-# dev-python/{,en}rich ebuilds do not support python3_10 yet.
-# We test fine (modulo some deprecation warnings) against 3.10 under tox, though.
-python_test() {
- if [[ ${EPYTHON} == "python3.10" ]]; then
- ewarn "Skipping tests for ${EPYTHON} due to missing dependencies"
- return 0
- fi
- if ! use test-full; then
- local -x EPYTEST_DESELECT=( "src/${PN/-/_}/test/test_func.py::test_molecule" )
- fi
- distutils-r1_python_test
-}