summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-10 04:33:54 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-10 04:33:54 +0200
commitc543521a74d122b94b24aef14ddc09923f030ad1 (patch)
treee26c868ae02b161f2aa9145862ebbd0bfd6ee39b /dev-python/sphinxcontrib-websupport
parentdev-libs/libmirage: Fix gcc-10 build (diff)
downloadgentoo-c543521a74d122b94b24aef14ddc09923f030ad1.tar.gz
gentoo-c543521a74d122b94b24aef14ddc09923f030ad1.tar.bz2
gentoo-c543521a74d122b94b24aef14ddc09923f030ad1.zip
dev-python/sphinxcontrib-websupport: Bump to 1.2.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-websupport')
-rw-r--r--dev-python/sphinxcontrib-websupport/Manifest1
-rw-r--r--dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-websupport/Manifest b/dev-python/sphinxcontrib-websupport/Manifest
index 78fe4fe4eb72..d2ce6a984d79 100644
--- a/dev-python/sphinxcontrib-websupport/Manifest
+++ b/dev-python/sphinxcontrib-websupport/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-websupport-1.2.2.gh.tar.gz 599606 BLAKE2B d7e5754491d0f4e4b508bb5ed58f41d6f57c8785ce2d658cd4beb658b9a01a453bd791e73deab703ebf17d18ddf0a3adc7c72a49e80c33475daca41666da694d SHA512 39d7d688515440fcf7a0df9cff60402499956da4c4d5de4e7b38982ff23ed837e7851a3c747135b9298d0df59f3055a8f588be78f10d98110ab50b8ab434db34
+DIST sphinxcontrib-websupport-1.2.4.gh.tar.gz 599695 BLAKE2B 909fc3dd77377769b6242963c2228a01dae4c73b2c1128094ecb5c113517ddb103498fa8615a0690cc41333778a21ba62a7638e36e3d82ad89c74b76156580a4 SHA512 4b5a382037988079e12e5c022ce0351c953e65dacfee7e3a63852370deddcee083cb65914b0bb9a8dc42481015f33d1ac2b5fea61c676ab947f8b0cbe331d7f6
diff --git a/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.4.ebuild b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.4.ebuild
new file mode 100644
index 000000000000..a2aab86657c2
--- /dev/null
+++ b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx websupport extension"
+HOMEPAGE="https://www.sphinx-doc.org
+ https://github.com/sphinx-doc/sphinxcontrib-websupport"
+# pypi tarball is missing templates
+SRC_URI="https://github.com/sphinx-doc/sphinxcontrib-websupport/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-serializinghtml[${PYTHON_USEDEP}]"
+# avoid circular dependency with sphinx
+PDEPEND="
+ >=dev-python/sphinx-1.5.3[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ >=dev-python/sqlalchemy-0.9[${PYTHON_USEDEP}]
+ >=dev-python/whoosh-2.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # breaks tests
+ sed -i -e '/pkg_resources/d' \
+ sphinxcontrib/websupport/__init__.py || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}