summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-05-30 22:49:24 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-31 12:49:59 +0200
commit89790f2a885855eaebf362113ac8317c438d14af (patch)
treeba296856a9dc3c8fd11ece0c0915380af8550fdc /dev-python/sphinx
parentdev-python/docutils: enable py3.12 (diff)
downloadgentoo-89790f2a885855eaebf362113ac8317c438d14af.tar.gz
gentoo-89790f2a885855eaebf362113ac8317c438d14af.tar.bz2
gentoo-89790f2a885855eaebf362113ac8317c438d14af.zip
dev-python/sphinx: enable py3.12
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx')
-rw-r--r--dev-python/sphinx/sphinx-6.2.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/sphinx/sphinx-6.2.1.ebuild b/dev-python/sphinx/sphinx-6.2.1.ebuild
index 798699cb893b..081700885831 100644
--- a/dev-python/sphinx/sphinx-6.2.1.ebuild
+++ b/dev-python/sphinx/sphinx-6.2.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -103,6 +103,8 @@ python_test() {
# TODO
tests/test_ext_autodoc_autoclass.py::test_classes
tests/test_ext_autodoc_autofunction.py::test_classes
+ tests/test_ext_math.py::test_imgmath_numfig_html
+ tests/test_ext_math.py::test_imgmath_png
tests/test_ext_inheritance_diagram.py::test_import_classes
# looks like a bug in lualatex
"tests/test_build_latex.py::test_build_latex_doc[lualatex-howto]"