summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-09 17:25:44 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-09 17:25:47 +0200
commite09488a7b46a9c5b31073a0be35fc65d9bb65442 (patch)
treeae9a7fc047d059f4241777eb03bba9f71cb33cd9 /dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4-r1.ebuild
parentnet-misc/lyricwikia: update EAPI 7 -> 8, pep517, py3.12 (diff)
downloadgentoo-e09488a7b46a9c5b31073a0be35fc65d9bb65442.tar.gz
gentoo-e09488a7b46a9c5b31073a0be35fc65d9bb65442.tar.bz2
gentoo-e09488a7b46a9c5b31073a0be35fc65d9bb65442.zip
dev-python/sphinx-multiversion: update EAPI 7 -> 8, pep517, py3.12
Closes: https://bugs.gentoo.org/909966 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4-r1.ebuild')
-rw-r--r--dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4-r1.ebuild b/dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..434de8f770d1
--- /dev/null
+++ b/dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Add support for multiple versions to sphinx"
+HOMEPAGE="https://github.com/Holzhaus/sphinx-multiversion"
+SRC_URI="https://github.com/Holzhaus/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/alabaster