summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-11-11 18:53:22 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-11-11 18:53:22 +0700
commit5ed49c425b4fcef263c9e1573f2b63f03198aee2 (patch)
tree13a123e0e4a6fb5b35ffff7be7593928e51379e6 /dev-python/speg/speg-0.3.ebuild
parenteclass: update darcs.eclass for EAPI 7 (diff)
downloadgentoo-5ed49c425b4fcef263c9e1573f2b63f03198aee2.tar.gz
gentoo-5ed49c425b4fcef263c9e1573f2b63f03198aee2.tar.bz2
gentoo-5ed49c425b4fcef263c9e1573f2b63f03198aee2.zip
dev-python/speg: initial import
Signed-off-by: Andrey Grozin <grozin@gentoo.org> Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-python/speg/speg-0.3.ebuild')
-rw-r--r--dev-python/speg/speg-0.3.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-python/speg/speg-0.3.ebuild b/dev-python/speg/speg-0.3.ebuild
new file mode 100644
index 000000000000..365e1144c657
--- /dev/null
+++ b/dev-python/speg/speg-0.3.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+DESCRIPTION="A PEG-based parser interpreter with memoization"
+HOMEPAGE="https://github.com/avakar/speg/"
+SRC_URI="https://github.com/avakar/speg/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""