summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-26 18:03:31 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-26 18:23:34 +0200
commit3aff0c30a6bdf056f5df97ed57ac9491a0c68f1c (patch)
treedbd6432ea65ae04eff5613761f2871bf4701e5a1 /dev-python/soupsieve
parentdev-python/html5lib: Port to py39 (diff)
downloadgentoo-3aff0c30a6bdf056f5df97ed57ac9491a0c68f1c.tar.gz
gentoo-3aff0c30a6bdf056f5df97ed57ac9491a0c68f1c.tar.bz2
gentoo-3aff0c30a6bdf056f5df97ed57ac9491a0c68f1c.zip
dev-python/soupsieve: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/soupsieve')
-rw-r--r--dev-python/soupsieve/soupsieve-1.9.5.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-python/soupsieve/soupsieve-1.9.5.ebuild b/dev-python/soupsieve/soupsieve-1.9.5.ebuild
index 0b5495a28693..6c09f781048d 100644
--- a/dev-python/soupsieve/soupsieve-1.9.5.ebuild
+++ b/dev-python/soupsieve/soupsieve-1.9.5.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
inherit distutils-r1
@@ -16,6 +16,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86"
IUSE="test"
+RESTRICT+=" !test? ( test )"
RDEPEND="
$(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' -2)
@@ -28,6 +29,4 @@ BDEPEND="${RDEPEND}
)
"
-RESTRICT+=" !test? ( test )"
-
distutils_enable_tests pytest