summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-27 18:14:39 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-27 19:24:31 +0200
commit38fb85afc5b3d8cd4dc7fb567bf22d0f77ab382f (patch)
treee830c75b913a94ad2fb9839fb77d1e018a95f6d4 /dev-python/send2trash
parentdev-python/nbclassic: Bump to 0.5.6 (diff)
downloadgentoo-38fb85afc5b3d8cd4dc7fb567bf22d0f77ab382f.tar.gz
gentoo-38fb85afc5b3d8cd4dc7fb567bf22d0f77ab382f.tar.bz2
gentoo-38fb85afc5b3d8cd4dc7fb567bf22d0f77ab382f.zip
dev-python/send2trash: Bump to 1.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/send2trash')
-rw-r--r--dev-python/send2trash/Manifest1
-rw-r--r--dev-python/send2trash/send2trash-1.8.2.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/send2trash/Manifest b/dev-python/send2trash/Manifest
index 75ff09ca0389..b593457ef3ab 100644
--- a/dev-python/send2trash/Manifest
+++ b/dev-python/send2trash/Manifest
@@ -1 +1,2 @@
+DIST Send2Trash-1.8.2.tar.gz 17487 BLAKE2B 3362a7e0c70f0e3f0f7a64676174d6c6f28290079590e08e4a746c0e19f96deca028aa521df58afa7f0ab47d78f286df01f98e903dfd771063af0ff40b4f6c08 SHA512 378107c8175e8d08566258daa13d3000e66ec03f732698180a2eb7f862c39d3c458be66ecf3f8864f559b961e29b777b8e7f5169468219e19723def62a69bb9c
DIST send2trash-1.8.0.gh.tar.gz 15040 BLAKE2B 06f6b0b9e4e9316bc60332ea76426922db6d35fa5d4e0602e91a58996bb55a2344d7d56547bdf21151641c5ec710b78b2b11c8fda158eb911155994c86d10078 SHA512 9dc15fbd262eb5a05a355b436c0e582e5ef9b484f859b53faafe6af5bd08ef88b9aa5121485c2fffb7dbe5aeeef29f6719035e08c61da273fd4fa51383b062fe
diff --git a/dev-python/send2trash/send2trash-1.8.2.ebuild b/dev-python/send2trash/send2trash-1.8.2.ebuild
new file mode 100644
index 000000000000..fd7d2c7a4f0c
--- /dev/null
+++ b/dev-python/send2trash/send2trash-1.8.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=Send2Trash
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sends files to the Trash (or Recycle Bin)"
+HOMEPAGE="
+ https://github.com/arsenetar/send2trash/
+ https://pypi.org/project/Send2Trash/
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest