summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-02 10:48:45 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-02 10:55:19 +0100
commitefd4082855e504afdc7bbfea9aef333eaa0311b8 (patch)
treebf39f1f65efe9a35c509a4243f9e15f583f05c1a /dev-python/semantic_version
parentdev-python/semantic_version: Add pypy3 love (diff)
downloadgentoo-efd4082855e504afdc7bbfea9aef333eaa0311b8.tar.gz
gentoo-efd4082855e504afdc7bbfea9aef333eaa0311b8.tar.bz2
gentoo-efd4082855e504afdc7bbfea9aef333eaa0311b8.zip
dev-python/semantic_version: Bump to 2.8.6_pre20211108 snap
Bump to a fresh snapshot that is compatible with django-4.0. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/semantic_version')
-rw-r--r--dev-python/semantic_version/Manifest1
-rw-r--r--dev-python/semantic_version/semantic_version-2.8.6_pre20211108.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/semantic_version/Manifest b/dev-python/semantic_version/Manifest
index 9b30957061e4..cd6cd538481b 100644
--- a/dev-python/semantic_version/Manifest
+++ b/dev-python/semantic_version/Manifest
@@ -1 +1,2 @@
+DIST python-semanticversion-81a4730778fba6b5c76242d3c8da6dace7e2ec0a.tar.gz 40289 BLAKE2B 3e41362b5905b69873b13aef3a5146f61991b9e7438c30351b45da420fe9acb41b03664c6c0981ae2e3e22b9f50c061da74742d999c1c5f87dbb2a365249f827 SHA512 db5bc2f40483f06ccebebbbfa14009a68e6d89ab7480d51a3cd26b10fbc9ab1b43def2ea402ceac9db16720d6226be91b04ecf34441b1d535819471007a02df6
DIST semantic_version-2.8.5.tar.gz 50009 BLAKE2B 5f966ca68358d4963b3a41574c100a8f78275445285aebbfa47d1febb0b7a2eb3a638254d4d1bd8e093acbef47a101ef0a0d7a86475313aefa211d2a0a3cfc19 SHA512 2ab59024c148239d78de062ff3a357f81a33fd066b6be8b6f9ef0753841a4945829b1c11899cfbda6c3ff09e00aa3b689e1fb6f8b9a92bbb3c2a62dd713b6049
diff --git a/dev-python/semantic_version/semantic_version-2.8.6_pre20211108.ebuild b/dev-python/semantic_version/semantic_version-2.8.6_pre20211108.ebuild
new file mode 100644
index 000000000000..fdf4d6145c6d
--- /dev/null
+++ b/dev-python/semantic_version/semantic_version-2.8.6_pre20211108.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+EGIT_COMMIT="81a4730778fba6b5c76242d3c8da6dace7e2ec0a"
+MY_P=python-semanticversion-${EGIT_COMMIT}
+DESCRIPTION="Python library providing a few tools handling SemVer in Python"
+HOMEPAGE="https://pypi.org/project/semantic-version/"
+SRC_URI="
+ https://github.com/rbarrois/python-semanticversion/archive/${EGIT_COMMIT}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:django
+}