summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/seaborn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/seaborn')
-rw-r--r--dev-python/seaborn/Manifest2
-rw-r--r--dev-python/seaborn/metadata.xml35
-rw-r--r--dev-python/seaborn/seaborn-0.5.1.ebuild37
-rw-r--r--dev-python/seaborn/seaborn-0.6.0.ebuild37
4 files changed, 111 insertions, 0 deletions
diff --git a/dev-python/seaborn/Manifest b/dev-python/seaborn/Manifest
new file mode 100644
index 000000000000..24006cdc7114
--- /dev/null
+++ b/dev-python/seaborn/Manifest
@@ -0,0 +1,2 @@
+DIST seaborn-0.5.1.tar.gz 104426 SHA256 8c8f7f1036cf6155be3d987ee23d2eeeed8c272b0803b32b7d524614f8526688 SHA512 bbcdf0625e096b8f41d56521f3e319a64d82632131d80ed1e81144362fe881d9b5df4d3b5a5fa09363b1782897d9ac68d3fc647d82da4e0017c5dba21c897b8d WHIRLPOOL 682a32f2d40a742e87659f27a675c437875a4b4dfcfd8195b774c49ae38f5ad73ee4b73aa00dabab33ccb6015e5eb5326605c897c8b1cac341cc9db0d6143f73
+DIST seaborn-0.6.0.tar.gz 145188 SHA256 e078399b56ed0d53a4aa8bd4d6bd4a9a9deebc0b4acad259d0ef81830affdb68 SHA512 3b7e7c1b72bd55aba012f312b43920044ea011648b4d855f4acd813ae644a75b4c60aa56c35ea759dcd7683bb6d9ea3b4f1209215950a5014ad46ebe04088fb1 WHIRLPOOL 66c9834f982f4a27c1a884bd4c8f73bb718fe0948bc7b3bde86f7d9bd354bbf783e36c576b8e2b0ded50cdf63244f463b9419e808ab70f6d5c2a24e89c570e99
diff --git a/dev-python/seaborn/metadata.xml b/dev-python/seaborn/metadata.xml
new file mode 100644
index 000000000000..13c0d0709aab
--- /dev/null
+++ b/dev-python/seaborn/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <longdescription lang="en">
+Seaborn is a library for making attractive and informative statistical graphics
+in Python. It is built on top of matplotlib and tightly integrated with the
+PyData stack, including support for numpy and pandas data structures and
+statistical routines from scipy and statsmodels.
+
+Some of the features that seaborn offers are
+
+* Several built-in themes that improve on the default matplotlib aesthetics
+* Tools for choosing color palettes to make beautiful plots that reveal
+ patterns in your data
+* Functions for visualizing univariate and bivariate distributions or for
+ comparing them between subsets of data
+* Tools that fit and visualize linear regression models for different kinds
+ of independent and dependent variables
+* Functions that visualize matrices of data and use clustering algorithms to
+ discover structure in those matrices
+* A function to plot statistical timeseries data with flexible estimation and
+ representation of uncertainty around the estimate
+* High-level abstractions for structuring grids of plots that let you easily
+ build complex visualizations
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">seaborne</remote-id>
+ <remote-id type="github">mwaskom/seaborn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/seaborn/seaborn-0.5.1.ebuild b/dev-python/seaborn/seaborn-0.5.1.ebuild
new file mode 100644
index 000000000000..50675a3099c6
--- /dev/null
+++ b/dev-python/seaborn/seaborn-0.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Statistical data visualization"
+HOMEPAGE="http://stanford.edu/~mwaskom/software/seaborn/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ dev-python/statsmodels[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ VIRTUALX_COMMAND="nosetests"
+ virtualmake --verbosity=3
+}
diff --git a/dev-python/seaborn/seaborn-0.6.0.ebuild b/dev-python/seaborn/seaborn-0.6.0.ebuild
new file mode 100644
index 000000000000..18e22f1910f8
--- /dev/null
+++ b/dev-python/seaborn/seaborn-0.6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Statistical data visualization"
+HOMEPAGE="http://stanford.edu/~mwaskom/software/seaborn/ https://github.com/mwaskom/seaborn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ dev-python/statsmodels[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ VIRTUALX_COMMAND="nosetests"
+ virtualmake --verbosity=3
+}