summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-21 22:04:29 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-21 22:36:17 +0100
commitfabf14753d5f453c2a6141a18fb6e17f1d95ca85 (patch)
tree81c2399b509413770a0cbc2f2947b9483f8d0794 /dev-python/scrypt
parentdev-python/test_server: Bump to 0.0.33 (diff)
downloadgentoo-fabf14753d5f453c2a6141a18fb6e17f1d95ca85.tar.gz
gentoo-fabf14753d5f453c2a6141a18fb6e17f1d95ca85.tar.bz2
gentoo-fabf14753d5f453c2a6141a18fb6e17f1d95ca85.zip
dev-python/scrypt: Bump to 0.8.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scrypt')
-rw-r--r--dev-python/scrypt/Manifest1
-rw-r--r--dev-python/scrypt/scrypt-0.8.20.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/scrypt/Manifest b/dev-python/scrypt/Manifest
index 105f62d1637d..14e9a5a8687a 100644
--- a/dev-python/scrypt/Manifest
+++ b/dev-python/scrypt/Manifest
@@ -1 +1,2 @@
DIST scrypt-0.8.18.tar.gz 56651 BLAKE2B d0e71e0677ab5f159da829eaf8e794fab9fa9290ff3688e525c4f2e9c60fda532d1c302fe4088bd8e88e06e926ef95d06bad145697e8a13e2662eda7027479b7 SHA512 b033203f65dd63c1e915eeff6232c01f806eb01d3ce18e753b6161ae667555095fe775585dd0d4e15ae228f2d4862860093c1a18d5b810b438d032df9fb24d81
+DIST scrypt-0.8.20.tar.gz 55874 BLAKE2B b31c7dcec735944f6162709ba6ceb90160b3c9c403121a47e62563f8d2fc50f0505f180d7c18fa2c8e9037a097ca3bffea4c54c1f3b6861004f65a189a20b576 SHA512 da8d34755d4b6c98dc57ff7baf17839cf2434a6d7eb9f6fdc69b3e458d41b4fc49f7fd3a5631318b82bc4b2e46dedb806035897bf1be5a4670b4120f6b46efbc
diff --git a/dev-python/scrypt/scrypt-0.8.20.ebuild b/dev-python/scrypt/scrypt-0.8.20.ebuild
new file mode 100644
index 000000000000..df17f0b1fb84
--- /dev/null
+++ b/dev-python/scrypt/scrypt-0.8.20.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Bindings for the scrypt key derivation function library"
+HOMEPAGE="https://github.com/holgern/py-scrypt/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND="dev-libs/openssl:0="
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest