summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-01 08:38:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-01 09:21:33 +0200
commitf378eb31839afe4a7a598bc91c6bb0d38217b7fb (patch)
treef423bf08b2744a7a4eb13751f2390f4cdfdeb7c8 /dev-python/s3transfer
parentdev-python/cfn-lint: Bump to 0.61.0 (diff)
downloadgentoo-f378eb31839afe4a7a598bc91c6bb0d38217b7fb.tar.gz
gentoo-f378eb31839afe4a7a598bc91c6bb0d38217b7fb.tar.bz2
gentoo-f378eb31839afe4a7a598bc91c6bb0d38217b7fb.zip
dev-python/s3transfer: Bump to 0.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/s3transfer')
-rw-r--r--dev-python/s3transfer/Manifest1
-rw-r--r--dev-python/s3transfer/s3transfer-0.6.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/s3transfer/Manifest b/dev-python/s3transfer/Manifest
index fd9b9479bcc5..cd7a4cd0693c 100644
--- a/dev-python/s3transfer/Manifest
+++ b/dev-python/s3transfer/Manifest
@@ -1 +1,2 @@
DIST s3transfer-0.5.2.tar.gz 134873 BLAKE2B 55adab89ca04a9ed1f0195237cab55f97769a8f865e645437df6d95effcf1a27a734f1577daa981261123b681044b540ebbb876e1a8a3b4cf1cf4e5018f2c213 SHA512 6b035ff5b33ba5c048f6921f72684802a9b12516c70c75bd153e481e62a768015f45f569aa88071f887839fd2e004b5f9202813926ca33d58c30793218d14083
+DIST s3transfer-0.6.0.tar.gz 134871 BLAKE2B 7ab84f22dc20751dd461857f93d7f1aad1490432ed25e7506c5abe61f79d1f3cafd8ddb190a0942a2c5a9947c5068fcf397dce34f255a246381f4cf1f0d09e7a SHA512 0c1c3306015cab4a4436b1d2fec6708e17f4c5111f8a265fbfe134defebda33a43bd985e559be993b6175af9eee142e9f27da123f8d14f77cfc59e48ca1b905f
diff --git a/dev-python/s3transfer/s3transfer-0.6.0.ebuild b/dev-python/s3transfer/s3transfer-0.6.0.ebuild
new file mode 100644
index 000000000000..3e06d52b561d
--- /dev/null
+++ b/dev-python/s3transfer/s3transfer-0.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="An Amazon S3 Transfer Manager"
+HOMEPAGE="
+ https://github.com/boto/s3transfer/
+ https://pypi.org/project/s3transfer/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-1.24.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest tests/{unit,functional}
+}