summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-11-04 11:05:17 +0100
committerMatt Turner <mattst88@gentoo.org>2020-11-04 20:38:21 -0500
commit7c2993ec975ff7ef642c43275dafa6aba45c7bbd (patch)
tree734d11a7f43d9b0cae5b429c857e80a5b5c74b3f /dev-python/rope
parentdev-python/ropemode: bump python targets to py3.8 (diff)
downloadgentoo-7c2993ec975ff7ef642c43275dafa6aba45c7bbd.tar.gz
gentoo-7c2993ec975ff7ef642c43275dafa6aba45c7bbd.tar.bz2
gentoo-7c2993ec975ff7ef642c43275dafa6aba45c7bbd.zip
dev-python/rope: clean up 0.16.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest1
-rw-r--r--dev-python/rope/rope-0.16.0.ebuild45
2 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index 2dc67ca0ba91..5fc4e2db8c19 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1,3 +1,2 @@
-DIST rope-0.16.0.tar.gz 243304 BLAKE2B 2c41572687ef245eb20abfccebcc9f12ecaa177be313cec59c85be5102b7358566570730a7140f952b0a1c515b479c3d21740d32d4678e65c4c572acf86f4e27 SHA512 33ba57b246337e413126309a521c54e861899b03fd250e148b97d9789cddf6eceab36609ea6e36e84ad1ac514bc3363f4937b01bcb96b6103c2a33bec1d4fb75
DIST rope-0.17.0.tar.gz 248629 BLAKE2B 7c9276b5f400dfa9661f81d365eac150a124620824d400131d5da7361475e5a2d548c8b53a88e61e7ae6e483a47c8ca4b8ca773235e209e8c6fb47b0088327fd SHA512 c27a17fdf73ed0ae85fe417132acd999452ae88a7b779d84fdf73134094fd34510ae08017dc24ddd7c34cb70353b5a43021229b88819002371790e7717b8ae46
DIST rope-0.18.0.tar.gz 249828 BLAKE2B 2aac0541936c671f9b70528da28b2c016f14c7a3e5f368aecb6a3f2a39d2b447d70943bf00b7a49702f5d341504da7398ca5b1240d625275f749de1e530fb178 SHA512 9f706da345866447ff7e4027e6f9f0719d4b823253155881efcdd3a9e9a6f42fa9e194cd9547df4a6f752ae0cec739045e52bb7edd5cfa04ad4079fe06808298
diff --git a/dev-python/rope/rope-0.16.0.ebuild b/dev-python/rope/rope-0.16.0.ebuild
deleted file mode 100644
index 7854b2c3f39a..000000000000
--- a/dev-python/rope/rope-0.16.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python refactoring library"
-HOMEPAGE="https://github.com/python-rope/rope"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-IUSE="doc"
-
-# Dependency for docbuild documentation which is not noted in
-# setup.py, using standard docutils builds docs successfully.
-DEPEND="doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-python3.7.patch
-)
-
-distutils_enable_tests pytest
-
-python_compile_all() {
- if use doc; then
- pushd docs > /dev/null || die
- mkdir build || die
- local i
- for i in ./*.rst; do
- rst2html.py $i > ./build/${i/rst/html} || die
- done
- popd > /dev/null || die
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/. )
- distutils-r1_python_install_all
-}