summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-04 23:29:21 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-05 08:16:29 +0100
commit44cfd5c4fb70189c09d9cd368b86717521752f51 (patch)
tree7928c4d3335b491e2419da1640adf40d81b0a5ee /dev-python/rich
parentdev-ruby/bundler: add 2.2.13 (diff)
downloadgentoo-44cfd5c4fb70189c09d9cd368b86717521752f51.tar.gz
gentoo-44cfd5c4fb70189c09d9cd368b86717521752f51.tar.bz2
gentoo-44cfd5c4fb70189c09d9cd368b86717521752f51.zip
dev-python/rich: Bump to 9.12.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-9.12.4.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 22831fe8e7bb..3d5e672971f1 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1 +1,2 @@
DIST rich-9.11.1.tar.gz 14050070 BLAKE2B 7dcae32743bfcbbab0af6896f72e865d2a72ab66545168544d065145cf10a2aab4785454e547f011219a85a8aa762f1ed5ebef2b9fb7f44225a2f776835b643d SHA512 2139cb6602d930e9bf1479456a8e6cee812237fb64073db3f23fd8eab64c1c2b3a83c6292f1f90652791100a93961d8ec8036e5d819f1e23159b6b9a75cd1f6c
+DIST rich-9.12.4.tar.gz 16204429 BLAKE2B b57d7dc7ad4463c85cbc43e0fd8afd9f0c5329cbe81eaac168895af3701091669e4b0b6fd0d2de2f5876405c5aae00ed77e77d1b317dbd20c7dd3e53deddf2ca SHA512 92feb4ceab4e10f33c0f4abec19a4ee5bdcf27139591b603aba98239483874089fbd33998a2f05f2b609799afa59cddbe1ee245a87c391d15f58887b21a138df
diff --git a/dev-python/rich/rich-9.12.4.ebuild b/dev-python/rich/rich-9.12.4.ebuild
new file mode 100644
index 000000000000..a62e88778e09
--- /dev/null
+++ b/dev-python/rich/rich-9.12.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/willmcgugan/rich"
+SRC_URI="https://github.com/willmcgugan/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}