summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-04-29 13:09:06 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-04-29 14:56:58 -0500
commita4f25608b8461fc8a1c6f25a16f6d668814c39a8 (patch)
tree36ed47d879157e5a4ff6b2a4599ce6ae8498c0e1 /dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild
parentdev-python/networkx-2.4-r1: Revbump, add py38 without pandas (diff)
downloadgentoo-a4f25608b8461fc8a1c6f25a16f6d668814c39a8.tar.gz
gentoo-a4f25608b8461fc8a1c6f25a16f6d668814c39a8.tar.bz2
gentoo-a4f25608b8461fc8a1c6f25a16f6d668814c39a8.zip
dev-python/restructuredtext-lint: 1.3.0 bump
tests seem to work for me... Closes: https://bugs.gentoo.org/720026 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild')
-rw-r--r--dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild b/dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild
new file mode 100644
index 000000000000..7821756a7efc
--- /dev/null
+++ b/dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Checks PyPI validity of reStructuredText"
+HOMEPAGE="https://pypi.org/project/restructuredtext_lint/"
+
+MY_P="restructuredtext_lint"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_P}/${MY_P}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_P}-${PV}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/docutils-0.11[${PYTHON_USEDEP}]
+ <dev-python/docutils-1.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -v || die
+}