summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-23 07:24:05 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-23 07:41:21 +0100
commit3d3836bc95997a9bab4d7404cc518150df0d526f (patch)
treef853c84452f7289a3e0b2b73a14c8f58e3fab686 /dev-python/requests-oauthlib
parentdev-python/podman: Bump to 5.0.0 (diff)
downloadgentoo-3d3836bc95997a9bab4d7404cc518150df0d526f.tar.gz
gentoo-3d3836bc95997a9bab4d7404cc518150df0d526f.tar.bz2
gentoo-3d3836bc95997a9bab4d7404cc518150df0d526f.zip
dev-python/requests-oauthlib: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/requests-oauthlib')
-rw-r--r--dev-python/requests-oauthlib/Manifest1
-rw-r--r--dev-python/requests-oauthlib/requests-oauthlib-2.0.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/requests-oauthlib/Manifest b/dev-python/requests-oauthlib/Manifest
index 95bf581c0d54..c087d7c1f373 100644
--- a/dev-python/requests-oauthlib/Manifest
+++ b/dev-python/requests-oauthlib/Manifest
@@ -1,2 +1,3 @@
DIST requests-oauthlib-1.3.1.tar.gz 48367 BLAKE2B 0cc538fe7ed1ef12740b60bb8b3e32d84f0d45b6c231c70b8bbfe9db9c8775acc51f50e78589e43eb0644c82e919a5a124941986023de4432e0631ebf0764869 SHA512 86fe34d39ad7224fd44a1b0c4fbf3784032239b894ae73ba65043941cde9675c2f8abedf44ccc00b5fb1648b8e261de258464b311f3ace6392ab6202fb50aa08
DIST requests-oauthlib-1.4.0.gh.tar.gz 51324 BLAKE2B e62d696ceaf483f5cbfacd60570a87665d7b7933d3c79de93ce7884c6ac9f245d5ba77f1e83c518226ec2be89c3e6ba4281669e1dcf83cffcddda95fd25ae2fe SHA512 14ffe34be4aaffb774aeda7965687738c12b23291994a86ee9c1436490cd20588bfeac4fb41b4cc89966f62a6ed5152235cd06cd194a8eecc8ea9367975d87ce
+DIST requests-oauthlib-2.0.0.gh.tar.gz 51357 BLAKE2B 1c1c8c2295f1bce2cb1da1c2fdd899004dfac2dc53956ebcd4affb9fcc6c11047545dec0b96311755d041694c07dcfccaff7ae479ecf7aaaf5ebcfb64665a76a SHA512 15d353da1422ce6f826b5cb3b26afeb597da4b1f0ffdf797f9cba75be4d8bbf00321dd697c1e368f6a8aeb92c57566725c745969fa7e8d60f690f79da13db867
diff --git a/dev-python/requests-oauthlib/requests-oauthlib-2.0.0.ebuild b/dev-python/requests-oauthlib/requests-oauthlib-2.0.0.ebuild
new file mode 100644
index 000000000000..fbe6ef8d3352
--- /dev/null
+++ b/dev-python/requests-oauthlib/requests-oauthlib-2.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="This project provides first-class OAuth library support for Requests"
+HOMEPAGE="
+ https://github.com/requests/requests-oauthlib/
+ https://pypi.org/project/requests-oauthlib/
+"
+SRC_URI="
+ https://github.com/requests/requests-oauthlib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet access
+ tests/test_core.py::OAuth1Test::testCanPostBinaryData
+ tests/test_core.py::OAuth1Test::test_content_type_override
+ tests/test_core.py::OAuth1Test::test_url_is_native_str
+ )
+ local EPYTEST_IGNORE=(
+ tests/examples
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}